Bug 608304 - Unable to update perl because of broken net-snmp-libs dependencies.
Summary: Unable to update perl because of broken net-snmp-libs dependencies.
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: net-snmp   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Jan Safranek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-26 18:26 UTC by Gene Snider
Modified: 2010-06-28 06:46 UTC (History)
1 user (show)

Fixed In Version: net-snmp-5.5-16.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 06:46:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gene Snider 2010-06-26 18:26:57 UTC
Description of problem:
The new perl update for rawhide replaces a module that net-snmp-libs depends on, see below.  So, net-snmp needs to be rebuilt against the new perl.

Version-Release number of selected component (if applicable):
net-snmp-libs-5.5-15.fc14.x86_64

How reproducible:
Easily.

Steps to Reproduce:
1. Run "sudo yum --nogpgcheck update"
2.
3.
  
Actual results:
Error: Package: 1:net-snmp-libs-5.5-15.fc14.x86_64 (@rawhide)
           Requires: perl(:MODULE_COMPAT_5.10.1)
           Removing: 4:perl-5.10.1-118.fc14.x86_64 (@rawhide)
               perl(:MODULE_COMPAT_5.10.1)
           Updated By: 4:perl-5.12.1-123.fc14.x86_64 (rawhide)
               Not found

Expected results:
Successful update.

Additional info:

Thanks,
Gene

Comment 1 Jan Safranek 2010-06-28 06:46:17 UTC
I've rebuilt net-snmp with new perl, it requires perl(:MODULE_COMPAT_5.12.1) now.


Note You need to log in before you can comment on or make changes to this bug.