Bug 608316 - Intel GMA HD : VGA output weavy
Intel GMA HD : VGA output weavy
Status: CLOSED DUPLICATE of bug 669724
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
14
All Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-26 15:37 EDT by Paul Ezvan
Modified: 2018-04-11 05:38 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-11 14:07:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log (105.46 KB, text/plain)
2010-06-26 15:37 EDT, Paul Ezvan
no flags Details
Dmesg with drm debug enabled (kernel 2.6.34-45) (86.23 KB, text/plain)
2010-06-30 03:30 EDT, Paul Ezvan
no flags Details
/var/log/messages (1.95 MB, text/plain)
2010-06-30 03:34 EDT, Paul Ezvan
no flags Details
mp4 format, recorded (238.20 KB, application/zip)
2011-02-14 13:26 EST, M K
no flags Details
Screencast of the issue (79.02 KB, application/webm)
2011-07-11 14:05 EDT, Matěj Cepl
no flags Details

  None (edit)
Description Paul Ezvan 2010-06-26 15:37:05 EDT
Created attachment 427125 [details]
Xorg log

Description of problem:
On my Dell Vostro 3300 Laptop, the VGA output is quite unusable, because there are sort of waves on the VGA connected screen. It happen on every TFT screen I have tested (3 at the moment).

Version-Release number of selected component (if applicable):
xorg-x11-drv-intel 2.11.0-4.fc13
kernel 2.6.33.5-124.fc13

How reproducible:
Always reproducible.

Steps to Reproduce:
1. Connect a VGA display to the VGA output
2. Waves are visible on the screen
  
Actual results:
Unreadable display

Expected results:

Perfect display
Comment 1 Matěj Cepl 2010-06-29 19:18:39 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please add drm.debug=0x04 to the kernel command line, restart computer, and attach

* your X server config file (/etc/X11/xorg.conf, if available),
* output of the dmesg command, and
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Paul Ezvan 2010-06-30 03:30:37 EDT
Created attachment 427895 [details]
Dmesg with drm debug enabled (kernel 2.6.34-45)
Comment 3 Paul Ezvan 2010-06-30 03:34:34 EDT
Created attachment 427897 [details]
/var/log/messages
Comment 4 Paul Ezvan 2010-06-30 03:36:27 EDT
There is no /etc/X11/xorg.conf.
Comment 5 Matěj Cepl 2010-07-12 13:56:04 EDT
(In reply to comment #3)
> Created an attachment (id=427897) [details]
> /var/log/messages    

Yes, I see many times:

Jun 29 13:32:12 gens kernel: Process Xorg (pid: 1635, threadinfo ffff880037a2c000, task ffff8800b2b62ea0)
Jun 29 13:32:12 gens kernel: Stack:
Jun 29 13:32:12 gens kernel: ffff880037a2dcd8 ffffffffa008a708 ffff880037a2dd08 ffffffffa006521e
Jun 29 13:32:12 gens kernel: <0> ffff8800b02a9900 ffff880037a2dda8 ffff8800b02fd800 ffff8800b02fda40
Jun 29 13:32:12 gens kernel: <0> ffff880037a2dd58 ffffffffa003612d 000000000000000a ffff8800b02fac08
Jun 29 13:32:12 gens kernel: Call Trace:
Jun 29 13:32:12 gens kernel: [<ffffffffa008a708>] ? intel_lvds_dpms+0x17/0x19 [i915]
Jun 29 13:32:12 gens kernel: [<ffffffffa006521e>] ? drm_helper_connector_dpms+0x118/0x204 [drm_kms_helper]
Jun 29 13:32:12 gens kernel: [<ffffffffa003612d>] ? drm_mode_connector_property_set_ioctl+0x103/0x170 [drm]
Jun 29 13:32:12 gens kernel: [<ffffffffa002c4ab>] ? drm_ioctl+0x254/0x365 [drm]
Jun 29 13:32:12 gens kernel: [<ffffffffa003602a>] ? drm_mode_connector_property_set_ioctl+0x0/0x170 [drm]
Jun 29 13:32:12 gens kernel: [<ffffffff811011a8>] ? do_sync_write+0xc6/0x103
Jun 29 13:32:12 gens kernel: [<ffffffff8110d98b>] ? vfs_ioctl+0x2d/0xa1
Jun 29 13:32:12 gens kernel: [<ffffffff8110def4>] ? do_vfs_ioctl+0x47e/0x4c4
Jun 29 13:32:12 gens kernel: [<ffffffff8110df8b>] ? sys_ioctl+0x51/0x74
Jun 29 13:32:12 gens kernel: [<ffffffff81009ac2>] ? system_call_fastpath+0x16/0x1b
Jun 29 13:32:12 gens kernel: Code: 31 81 ce 00 00 00 80 41 89 31 48 03 50 18 8b 12 45 89 c0 4c 03 40 18 41 8b 10 83 ca 01 41 89 10 89 c9 48 89 ca 48 03 50 18 8b 12 <85> d2 79 f3 48 8b 97 88 03 00 00 8b b0 c8 04 00 00 48 8b 42 08 
Jun 29 13:32:12 gens kernel: Call Trace:
Jun 29 13:32:12 gens kernel: [<ffffffffa008a708>] ? intel_lvds_dpms+0x17/0x19 [i915]
Jun 29 13:32:12 gens kernel: [<ffffffffa006521e>] ? drm_helper_connector_dpms+0x118/0x204 [drm_kms_helper]
Jun 29 13:32:12 gens kernel: [<ffffffffa003612d>] ? drm_mode_connector_property_set_ioctl+0x103/0x170 [drm]
Jun 29 13:32:12 gens kernel: [<ffffffffa002c4ab>] ? drm_ioctl+0x254/0x365 [drm]
Jun 29 13:32:12 gens kernel: [<ffffffffa003602a>] ? drm_mode_connector_property_set_ioctl+0x0/0x170 [drm]
Jun 29 13:32:12 gens kernel: [<ffffffff811011a8>] ? do_sync_write+0xc6/0x103
Jun 29 13:32:12 gens kernel: [<ffffffff8110d98b>] ? vfs_ioctl+0x2d/0xa1
Jun 29 13:32:12 gens kernel: [<ffffffff8110def4>] ? do_vfs_ioctl+0x47e/0x4c4
Jun 29 13:32:12 gens kernel: [<ffffffff8110df8b>] ? sys_ioctl+0x51/0x74
Jun 29 13:32:12 gens kernel: [<ffffffff81009ac2>] ? system_call_fastpath+0x16/0x1b
Jun 29 13:33:18 gens kernel: BUG: soft lockup - CPU#3 stuck for 61s! [Xorg:1635]
Comment 6 Joel Bastos 2010-10-20 07:25:55 EDT
The EXACT same problem happens to me on Vostro 3300:

xorg-x11-drv-intel-2.12.0-6.fc14.1.i686
kernel 2.6.35.6-43.fc14.i686

Thanks.
Comment 7 Joel Bastos 2010-11-08 07:47:37 EST
Any update on this situation?

The problem still occurs on Fedora 14 Final:
xorg-x11-drv-intel-2.12.0-6.fc14.1.i686
Kernel 2.6.35.6-48.fc14.i686

Thanks.
Comment 8 M K 2011-02-14 13:26:35 EST
Created attachment 478683 [details]
mp4 format, recorded

mp4 format of recorded bug on VGA display
Comment 9 M K 2011-02-14 13:27:25 EST
Same problem on same laptop. I believe it is linked with Intel Corporation Core Processor Integrated Graphics Controller - I found people complaining about this bug at other places, with this thing in common.

I attached video of bug. Sorry for double-post.
Comment 10 M K 2011-02-16 08:38:27 EST
Tried with latest Fedora 15 kernel, still not working. Any update on progress ?
Comment 11 JAlberto 2011-07-01 03:25:13 EDT
Same problem here with F15,when i connect the monitor to a ubuntu system (same laptop) it works correctly
Comment 12 M K 2011-07-01 04:00:21 EDT
Bug still remains even on latest F15, same notebook.
Comment 13 Joel Bastos 2011-07-01 05:13:47 EDT
Same here, problem continues on F15.

Kernel: 2.6.38.8-32.fc15.i686
Comment 14 M K 2011-07-03 11:54:00 EDT
Problem stays on latest Ubuntu (64b) for me. JAlberto do you have 32b Ubuntu or 64b ?
Comment 15 JAlberto 2011-07-03 12:09:58 EDT
M K 64 w/o unity
Comment 16 Javier Jardón 2011-07-06 05:45:15 EDT
Could someone mark this bug as duplicate of bug #669724 ?
Comment 17 Matěj Cepl 2011-07-11 14:05:27 EDT
Created attachment 512271 [details]
Screencast of the issue
Comment 18 Matěj Cepl 2011-07-11 14:07:58 EDT
(In reply to comment #16)
> Could someone mark this bug as duplicate of bug #669724 ?

Right.

*** This bug has been marked as a duplicate of bug 669724 ***

Note You need to log in before you can comment on or make changes to this bug.