Bug 608341 - upower-0.9.4-1.fc13.x86_64 is confused about battery size by a factor of 10
upower-0.9.4-1.fc13.x86_64 is confused about battery size by a factor of 10
Status: CLOSED DUPLICATE of bug 656738
Product: Fedora
Classification: Fedora
Component: upower (Show other bugs)
14
All Linux
low Severity high
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-26 17:55 EDT by Olivier Crête
Modified: 2010-12-27 11:17 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-27 11:17:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Olivier Crête 2010-06-26 17:55:09 EDT
Description of problem:

When my battery is full, upower thinks its at 10%.

See below.. EnergyFull is 10 times what it should be

Version-Release number of selected component (if applicable):

upower-0.9.4-1.fc13.x86_64

Additional info:

$ dbus-send --system --print-reply --dest=org.freedesktop.UPower /org/freedesktop/UPower/devices/battery_BAT0 org.freedesktop.DBus.Properties.GetAll string:"org.freedesktop.UPower.Device"
method return sender=:1.21 -> dest=:1.771 reply_serial=2
   array [
      dict entry(
         string "NativePath"
         variant             string "/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:09/PNP0C09:00/PNP0C0A:00/power_supply/BAT0"
      )
      dict entry(
         string "Vendor"
         variant             string "SANYO"
      )
      dict entry(
         string "Model"
         variant             string "42T4647"
      )
      dict entry(
         string "Serial"
         variant             string "2213"
      )
      dict entry(
         string "UpdateTime"
         variant             uint64 1277589125
      )
      dict entry(
         string "Type"
         variant             uint32 2
      )
      dict entry(
         string "PowerSupply"
         variant             boolean true
      )
      dict entry(
         string "HasHistory"
         variant             boolean true
      )
      dict entry(
         string "HasStatistics"
         variant             boolean true
      )
      dict entry(
         string "Online"
         variant             boolean false
      )
      dict entry(
         string "Energy"
         variant             double 59.886
      )
      dict entry(
         string "EnergyEmpty"
         variant             double 0
      )
      dict entry(
         string "EnergyFull"
         variant             double 601.884
      )
      dict entry(
         string "EnergyFullDesign"
         variant             double 60.6528
      )
      dict entry(
         string "EnergyRate"
         variant             double 23.976
      )
      dict entry(
         string "Voltage"
         variant             double 12.086
      )
      dict entry(
         string "TimeToEmpty"
         variant             int64 8991
      )
      dict entry(
         string "TimeToFull"
         variant             int64 0
      )
      dict entry(
         string "Percentage"
         variant             double 9.94976
      )
      dict entry(
         string "IsPresent"
         variant             boolean true
      )
      dict entry(
         string "State"
         variant             uint32 2
      )
      dict entry(
         string "IsRechargeable"
         variant             boolean true
      )
      dict entry(
         string "Capacity"
         variant             double 100
      )
      dict entry(
         string "Technology"
         variant             uint32 1
      )
      dict entry(
         string "RecallNotice"
         variant             boolean false
      )
      dict entry(
         string "RecallVendor"
         variant             string ""
      )
      dict entry(
         string "RecallUrl"
         variant             string ""
      )
   ]
Comment 1 Olivier Crête 2010-06-26 17:56:51 EDT
Btw, rm /var/lib/upower/* && killall upowerd && restarting it did fix the problem (for now)
Comment 2 Richard Hughes 2010-06-27 03:28:07 EDT
Looks like a hardware problem. What hardware is this?
Comment 3 Olivier Crête 2010-06-27 04:55:14 EDT
Thinkpad x201
Comment 4 Olivier Crête 2010-07-04 20:58:59 EDT
It seems that just restarting upower fixes it (removing the history wasn't necessary..).. Like like the energy-full-design's real value is like 600Wh. I think it may have something to do with charging to full (which is over the stated design) while the computer is suspended.
Comment 5 Christopher J Suleski 2010-10-27 13:11:18 EDT
I have the same exact issue on a Thinkpad T410. The problem happens when I'm charging the laptop while suspended. When I open it back up, energy-full-design's 10x higher than it should be. Suspending and resuming on battery power temporarily clears the issue.

This issue still presents on upower-0.9.5-7.fc14.x86_64

This is not a (consistent) hardware bug as the data in /sys is correct. Perhaps that data is incorrect for a few seconds on resume?


# cat /sys/devices/LNXSYSTM\:00/LNXSYBUS\:00/PNP0A08\:00/device\:09/PNP0C09\:00/PNP0C0A\:00/power_supply/BAT0/charge_full
9378000


# cat /sys/devices/LNXSYSTM\:00/LNXSYBUS\:00/PNP0A08\:00/device\:09/PNP0C09\:00/PNP0C0A\:00/power_supply/BAT0/charge_full_design 
9396000


# cat /sys/devices/LNXSYSTM\:00/LNXSYBUS\:00/PNP0A08\:00/device\:09/PNP0C09\:00/PNP0C0A\:00/power_supply/BAT0/charge_now 
9240000


# upower -d
Device: /org/freedesktop/UPower/devices/battery_BAT0
  native-path:          /sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:09/PNP0C09:00/PNP0C0A:00/power_supply/BAT0
  vendor:               Panasonic
  model:                42T4801
  serial:               24963
  power supply:         yes
  updated:              Wed Oct 27 12:59:49 2010 (11 seconds ago)
  has history:          yes
  has statistics:       yes
  battery
    present:             yes
    rechargeable:        yes
    state:               discharging
    energy:              100.397 Wh
    energy-empty:        0 Wh
    energy-full:         1013.69 Wh
    energy-full-design:  101.477 Wh
    energy-rate:         22.2372 W
    voltage:             12.268 V
    time to empty:       4.5 hours
    percentage:          9.90411%
    capacity:            99.9894%
    technology:          lithium-ion
  History (charge):
    1288198789	9.904	discharging
    1288198759	9.923	discharging
    1288198729	9.945	discharging
    1288198699	9.967	discharging
  History (rate):
    1288198789	22.237	discharging
    1288198759	22.475	discharging
    1288198729	22.626	discharging
    1288198699	20.930	discharging

Daemon:
  daemon-version:  0.9.5
  can-suspend:     yes
  can-hibernate    yes
  on-battery:      yes
  on-low-battery:  yes
  lid-is-closed:   no
  lid-is-present:   yes
Comment 6 Olivier Crête 2010-11-12 13:30:40 EST
I can confirm that suspending/resuming on battery power fixes the issue here too. And it still happens with F14.
Comment 7 Olivier Crête 2010-12-27 11:17:31 EST
Looks like the kernel bug was found and fixed in bug #656738

*** This bug has been marked as a duplicate of bug 656738 ***

Note You need to log in before you can comment on or make changes to this bug.