Bug 608389 - rebuild for perl-5.12 needed
Summary: rebuild for perl-5.12 needed
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-v2v (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Matthew Booth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-27 07:11 UTC by Ralf Corsepius
Modified: 2010-07-01 08:50 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-30 13:05:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ralf Corsepius 2010-06-27 07:11:31 UTC
Description of problem:

virt-v2v would need a rebuild for perl-5.12.

I would have rebuilt it, unfortunately virt-v2v currently fails to build in rawhide, because of other issues.

Version-Release number of selected component (if applicable):
virt-v2v-0.4.0-1.fc14 (current rawhide)
rsp.
virt-v2v-0.6.1-0.fc14 (current cvs).

Additional info:
This is package is one of the very few remaining packages still lacking a rebuild for perl-5.12.

Comment 1 Matthew Booth 2010-06-30 13:05:46 UTC
I've fixed the outstanding issues with this package and rebuilt it.

Comment 2 Ralf Corsepius 2010-07-01 05:25:46 UTC
Matt, 2 remarks:

- rpmlint virt-v2v-0_6_1-0_fc14/virt-v2v-0.6.1-0.fc14.x86_64.rpm 
virt-v2v.x86_64: W: incoherent-version-in-changelog 0.6.1 ['0.6.1-0.fc14', '0.6.1-0']

The %release in %changelog doesn't match this package's actual $release 
(*-1 vs. *-0)

- Is this package really arch'ed?
I am inclined to think it might be noarch'ed. 
It doesn't contain any binary nor can I spot any architecture specific details.
(May-be /etc/*.conf is arch'ed, I am not sure).

Comment 3 Ralf Corsepius 2010-07-01 06:23:04 UTC
(In reply to comment #2)
> - Is this package really arch'ed?
I just checked. It indeed is noarch'ed.

Comment 4 Matthew Booth 2010-07-01 08:50:57 UTC
(In reply to comment #3)
> (In reply to comment #2)
> > - Is this package really arch'ed?
> I just checked. It indeed is noarch'ed.    

I've lost the ExclusiveArch directive in an update. Manual patching failure.

However, despite being really noarch, it unfortunately can't be built noarch. Here's the full comment from another branch:

# Unfortunately, despite really being noarch, we have to make virt-v2v arch
# dependent to avoid build failures on architectures where libguestfs isn't
# available.
ExclusiveArch:  %{ix86} x86_64

It's ultimately dependent on the architecture availability of kvm. This is an unfortunate quirk of the build system. If you make it noarch the build will fail non-deterministically dependent on which architecture build machine it is assigned to.

And you're absolutely right, I messed up the changelog too. I'll fix both issues now.


Note You need to log in before you can comment on or make changes to this bug.