Bug 608437 - yum upgrade from F11 to F13 : missing dependency libedataserver-1.2.so.11()(64bit)
Summary: yum upgrade from F11 to F13 : missing dependency libedataserver-1.2.so.11()(6...
Status: CLOSED DUPLICATE of bug 608212
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution   
(Show other bugs)
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-27 14:27 UTC by Matthieu Araman
Modified: 2014-01-21 23:15 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 09:47:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matthieu Araman 2010-06-27 14:27:21 UTC
Description of problem:
Tryingto upgrade from F11 to F13 following instructions at http://fedoraproject.org/wiki/Upgrading_Fedora_using_yum

Version-Release number of selected component (if applicable):
F11 -> F13

How reproducible:
Always

Steps to Reproduce:
1.Install F11 + updates (box wasn't updated for a while)
2.install rpm -Uvh Fedora-release...13.rpm
3.yum upgrade
  
Actual results:
depency error 
 libedataserver-1.2.so.11()(64bit)
missing for these rpms
gnome-panel   (which I think will be needed...)
nautilus-sendto
empathy
ekiga
pidgin-evolution



Expected results:
yum should resolve the dependency 
on a installed F13 box, I get rpm -qf /usr/lib/libedataserver-1.2.so.11.0.1 
evolution-data-server-2.30.1-2.fc13.i686



Additional info:
I didn't find any mean to tell yum upgrade to add this package to the list while doing the upgrade (ie yum upgrade --addpackage evolution-data-server

Comment 1 seth vidal 2010-06-28 03:32:32 UTC
broken dep in the repo.

Comment 2 odaiwai 2010-06-28 06:17:36 UTC
I get the same result when doing a yum update after upgrading from F12 to F13 using Preupgrade.  Outcomes as below:

[root@gizmo ~]# yum update
Loaded plugins: presto, refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: libedataserver-1.2.so.11()(64bit) for package: gnome-panel-2.30.0-1.fc13.x86_64
--> Processing Dependency: libedataserver-1.2.so.11()(64bit) for package: ekiga-3.2.7-1.fc13.x86_64
--> Processing Dependency: libedataserver-1.2.so.11()(64bit) for package: nautilus-sendto-2.28.4-1.fc13.x86_64
---> Package evolution-data-server.x86_64 0:2.30.2-2.fc13 set to be updated
---> Package evolution-data-server-devel.x86_64 0:2.30.2-2.fc13 set to be updated
--> Finished Dependency Resolution
Error: Package: gnome-panel-2.30.0-1.fc13.x86_64 (@anaconda-InstallationRepo-201005130101.x86_64)
           Requires: libedataserver-1.2.so.11()(64bit)
           Removing: evolution-data-server-2.30.1-2.fc13.x86_64 (@anaconda-InstallationRepo-201005130101.x86_64)
Error: Package: ekiga-3.2.7-1.fc13.x86_64 (@anaconda-InstallationRepo-201005130101.x86_64)
           Requires: libedataserver-1.2.so.11()(64bit)
           Removing: evolution-data-server-2.30.1-2.fc13.x86_64 (@anaconda-InstallationRepo-201005130101.x86_64)
Error: Package: nautilus-sendto-2.28.4-1.fc13.x86_64 (@anaconda-InstallationRepo-201005130101.x86_64)
           Requires: libedataserver-1.2.so.11()(64bit)
           Removing: evolution-data-server-2.30.1-2.fc13.x86_64 (@anaconda-InstallationRepo-201005130101.x86_64)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Comment 3 Peter van Ieperen 2010-06-28 09:44:49 UTC
Same problem exists on Fedora 13 itself when doing update.

sudo yum update
Loaded plugins: fastestmirror, presto, refresh-packagekit, remove-with-leaves,
              : upgrade-helper, versionlock
Loading mirror speeds from cached hostfile
 * fedora: ftp.klid.dk
 * livna: wftp.tu-chemnitz.de
 * rpmfusion-free: mirror.andreas-mueller.com
 * rpmfusion-free-updates: mirror.andreas-mueller.com
 * rpmfusion-nonfree: mirror.andreas-mueller.com
 * rpmfusion-nonfree-updates: mirror.andreas-mueller.com
 * updates: ftp.wsisiz.edu.pl
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package evolution.x86_64 0:2.30.2-1.fc13 set to be updated
---> Package evolution-conduits.x86_64 0:2.30.2-1.fc13 set to be updated
--> Processing Dependency: libedataserver-1.2.so.11()(64bit) for package: ekiga-3.2.7-1.fc13.x86_64
--> Processing Dependency: libedataserver-1.2.so.11()(64bit) for package: nautilus-sendto-2.28.4-1.fc13.x86_64
--> Processing Dependency: libedataserver-1.2.so.11()(64bit) for package: evolution-sharp-0.21.1-5.fc13.x86_64
--> Processing Dependency: libedataserver-1.2.so.11()(64bit) for package: empathy-2.30.1.1-1.fc13.x86_64
--> Processing Dependency: libedataserver-1.2.so.11()(64bit) for package: mail-notification-evolution-plugin-5.4-20.fc13.x86_64
--> Processing Dependency: libedataserver-1.2.so.11()(64bit) for package: glabels-2.2.8-1.fc13.x86_64
--> Processing Dependency: libedataserver-1.2.so.11()(64bit) for package: pidgin-evolution-2.7.1-2.fc13.x86_64
--> Processing Dependency: libedataserver-1.2.so.11()(64bit) for package: gnome-panel-2.30.0-1.fc13.x86_64
--> Processing Dependency: libedataserver-1.2.so.11()(64bit) for package: gnome-phone-manager-0.65-5.fc12.x86_64
---> Package evolution-data-server.i686 0:2.30.2-2.fc13 set to be updated
---> Package evolution-data-server.x86_64 0:2.30.2-2.fc13 set to be updated
---> Package evolution-data-server-devel.x86_64 0:2.30.2-2.fc13 set to be updated
---> Package evolution-devel.x86_64 0:2.30.2-1.fc13 set to be updated
---> Package evolution-help.noarch 0:2.30.2-1.fc13 set to be updated
---> Package evolution-perl.x86_64 0:2.30.2-1.fc13 set to be updated
--> Finished Dependency Resolution
Error: Package: gnome-phone-manager-0.65-5.fc12.x86_64 (@fedora/12)
           Requires: libedataserver-1.2.so.11()(64bit)
           Removing: evolution-data-server-2.30.1-2.fc13.x86_64 (@fedora)
Error: Package: ekiga-3.2.7-1.fc13.x86_64 (@updates)
           Requires: libedataserver-1.2.so.11()(64bit)
           Removing: evolution-data-server-2.30.1-2.fc13.x86_64 (@fedora)
Error: Package: evolution-sharp-0.21.1-5.fc13.x86_64 (@fedora)
           Requires: libedataserver-1.2.so.11()(64bit)
           Removing: evolution-data-server-2.30.1-2.fc13.x86_64 (@fedora)
Error: Package: gnome-panel-2.30.0-1.fc13.x86_64 (@fedora)
           Requires: libedataserver-1.2.so.11()(64bit)
           Removing: evolution-data-server-2.30.1-2.fc13.x86_64 (@fedora)
Error: Package: empathy-2.30.1.1-1.fc13.x86_64 (@updates)
           Requires: libedataserver-1.2.so.11()(64bit)
           Removing: evolution-data-server-2.30.1-2.fc13.x86_64 (@fedora)
Error: Package: mail-notification-evolution-plugin-5.4-20.fc13.x86_64 (@updates)
           Requires: libedataserver-1.2.so.11()(64bit)
           Removing: evolution-data-server-2.30.1-2.fc13.x86_64 (@fedora)
Error: Package: pidgin-evolution-2.7.1-2.fc13.x86_64 (@updates)
           Requires: libedataserver-1.2.so.11()(64bit)
           Removing: evolution-data-server-2.30.1-2.fc13.x86_64 (@fedora)
Error: Package: glabels-2.2.8-1.fc13.x86_64 (@updates)
           Requires: libedataserver-1.2.so.11()(64bit)
           Removing: evolution-data-server-2.30.1-2.fc13.x86_64 (@fedora)
Error: Package: nautilus-sendto-2.28.4-1.fc13.x86_64 (@fedora)
           Requires: libedataserver-1.2.so.11()(64bit)
           Removing: evolution-data-server-2.30.1-2.fc13.x86_64 (@fedora)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Comment 4 Milan Crha 2010-06-28 09:47:13 UTC

*** This bug has been marked as a duplicate of bug 608212 ***


Note You need to log in before you can comment on or make changes to this bug.