Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 608452 - /usr/lib64/libgd.so is in gd-devel, but /usr/lib64/libgd.so.2 is in gd
/usr/lib64/libgd.so is in gd-devel, but /usr/lib64/libgd.so.2 is in gd
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gd (Show other bugs)
13
All Linux
low Severity low
: ---
: ---
Assigned To: Jiri Moskovcak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-27 12:13 EDT by Jim Cromie
Modified: 2015-02-01 17:52 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-27 12:58:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Cromie 2010-06-27 12:13:52 EDT
Description of problem:

cpan> install GD fails on F-13 (and earlier I think)

this is because the .so symbolic link is in the -devel package,
not the base package.

I dont understand why the symlink isnt also in the base package,
since programs wanting libgd shouldnt have to ask for a specific
version, unless they actually need that version.

Once I installed gd-devel, cpan install worked as expected.
Comment 1 Patrice Dumas 2010-06-27 12:58:44 EDT
Unless I am missing something, you are rebuilding some code against GD. So in that case you need the -devel package. The .so is not needed at runtime, so it is not shipped in the base package (and it is the case for all the libraries in fedora).

Note You need to log in before you can comment on or make changes to this bug.