Bug 60850 - Windowmaker selected, not started
Windowmaker selected, not started
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: switchdesk (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-07 16:43 EST by Gene Czarcinski
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-21 17:47:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2002-03-07 16:43:17 EST
Description of Problem:
Selecting Window Maker on the gdm panel does not start windowmaker.  Instead,
sawfish and gnome are started.

Version-Release number of selected component (if applicable):


How Reproducible:
everytime

Steps to Reproduce:
1. freshh install gnome, kde and windowmaker
2. log on specifying windowmaker to gdm
3. 

Actual Results:
sawfish/gnome started

Expected Results:
Windowmaker started

Additional Information:

I believe that the reason that windowmaker is not started is that
/etc/X11/xdm/Xsession does not have a "Windowmaker" option.  This is likely
complicated by the fact that you really need to run "wmaker.inst" before
starting but even after running wmaker.inst and renaming .xinitrc, it will not
start.

I realize that this will be complicated to implement but if it is a gdm session
option, then it should work.  Otherwise, the gdm session option should be deleted.
Comment 1 Havoc Pennington 2002-03-07 17:10:29 EST
WindowMaker installs the gdm session I believe. It may be an xinitrc bug that 
the WindowMaker session doesn't work, though.
Comment 2 Gene Czarcinski 2002-03-18 12:47:09 EST
I have traced the bug to switchdesk.  The current set of the gdm and xinitrc
(/ext/X11/xdm/Xsession) packages use the parameter "wmaker" and NOT
"windowmaker" if Window Maker is selected by gdm.

The switchdesk package provides the file
/usr/share/apps/switchdesk/Xclients.windowmaker and this should be
/usr/share/apps/switchdesk/Xclients.wmaker

This bug may need to be reassigned to another person.  I am not sure this is
done automatically when this update is made.
Comment 3 Phil Copeland 2002-03-18 14:43:43 EST
Catch!... (lobs bug)
Comment 4 Havoc Pennington 2002-03-18 18:45:08 EST
switchdesk 3.9.7-5 should contain a working fix.
Comment 5 Gene Czarcinski 2002-03-21 10:49:53 EST
I am reopening this because 3.9.7-5 is NOT in beta3 or in the rawhide trees on
either the ftp.redhat.com OR the ftp.beta.redhat.com servers.
Comment 6 Havoc Pennington 2002-03-21 17:47:53 EST
It's in the internal tree that gets periodically synced to rawhide.
It will be along.

Note You need to log in before you can comment on or make changes to this bug.