Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 608511 - Startup of thunderbird 3.1 broken (must delete extension.ini from profile)
Startup of thunderbird 3.1 broken (must delete extension.ini from profile)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
13
All Linux
low Severity high
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-27 18:53 EDT by Stefan Neufeind
Modified: 2010-07-22 14:25 EDT (History)
5 users (show)

See Also:
Fixed In Version: 3.1.1-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-22 14:25:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Neufeind 2010-06-27 18:53:04 EDT
Thunderbird always worked fine for me including version 3.0.4. The extensions I use simply had their maxVersion raised to 3.1.x, since afaik no API-incompatible changes were introduced towards 3.1.
But since 3.1 now thunderbird doesn't startup anymore. Trying to start it from console looks like it does something, comes back immediately but doesn't show any sign of Thunderbird starting up. I suspect it immediately crashes/shuts down again.

Removing the "extensions.ini" from the profile-directory helps. Thunderbird starts up fine, detects the extensions again (they all work fine) and a new extensions.ini is written to disk. But upon next Thunderbird-restart you'll have to kill that extensions.ini again :-(
Comment 1 Remi Collet 2010-06-30 01:12:01 EDT
This bug affects latest version of lightning (fedora repo) and enigmail (rpmfusion repo).
See #608489 and comments in bodhi update for F-13.

It can be reproduce with a new profile, under i386 and x86_64.
Can't say if it is language (non-english) specific, but, at least "fr" users are affected (and probably "de", as Stefan).
Comment 2 Christopher Aillon 2010-06-30 01:29:09 EDT
See also https://bugzilla.mozilla.org/show_bug.cgi?id=574458
Comment 3 Remi Collet 2010-07-01 11:56:11 EDT
From comment in update
> xhorak - 2010-07-01 12:12:14 (karma: 0)
> It seems that mozilla is having problem with extensions located in symlinked
> directories (this is case of lightning):
> https://bugzilla.mozilla.org/show_bug.cgi?id=574458  
> The shredder problem is covered here:
> https://bugzilla.mozilla.org/show_bug.cgi?id=575224
> Thanks for testing and feedback.

I have test to remove symlinks and copy lightning + lightning-gdata + enigmail in extensions folder. Thunderbird works fine.

- as thunderbird (like firefox) folder seems now stable /usr/lib(64)/thunderbird-3.1 for all minor release
- as a new major version will change folder, but also (generally) breaks plugin compatibility

I think we probably could directly install lightning + enigmail in extension without use the symlink workaround (required in previous fedora version)

Other solution is to wait for a fix to mozilla bug 574458

What your thoughts ?
Comment 4 Jonathan Peatfield 2010-07-07 20:19:14 EDT
Well https://bugzilla.redhat.com/show_bug.cgi?id=574458 apparently won't be fixed since a fix for https://bugzilla.mozilla.org/show_bug.cgi?id=551152 is in Trunk:

  they've indicated they aren't interested in backporting the changes. there's
  nothing more to discuss anywhere.

and any other bug reports will just get closed.  Apparently that counts as fixed.
Comment 5 Julian Sikorski 2010-07-22 14:25:29 EDT
This seems to be fixed in 3.1.1.

Note You need to log in before you can comment on or make changes to this bug.