Bug 608514 - Atop's logrotate configuration is unnecessary
Summary: Atop's logrotate configuration is unnecessary
Keywords:
Status: CLOSED DUPLICATE of bug 542598
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: atop
Version: el5
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kairo Francisco de Araujo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-27 23:48 UTC by Brian Pitts
Modified: 2010-06-28 14:42 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-28 14:42:25 UTC


Attachments (Terms of Use)

Description Brian Pitts 2010-06-27 23:48:12 UTC
Description of problem:
Logrotate rotates atop's log files, but atop already handles this. Logrotate's renaming of the log files breaks the ability to use 'atop -r YYYYMMDD' to open a past day's data without specifying the path to the rawfile.

Version-Release number of selected component (if applicable):
atop-1.23-8.el5
logrotate-3.7.4-9

How reproducible:
Always.

Steps to Reproduce:
1. Install atop
2. Wait several days for atop's cron job and logrotate to run
  
Actual results:
A series of files like the following in /var/log/atop/.

-rw------- 1 root root        0 Jun 27 04:02 atop_20100626
-rw-r--r-- 1 root root 12592860 Jun 27 00:00 atop_20100626.1
-rw-r--r-- 1 root root 14081677 Jun 27 19:42 atop_20100627

Expected results:
A series of files like the following in /var/log/atop.

-rw-r--r-- 1 root root 12592860 Jun 27 00:00 atop_20100626
-rw-r--r-- 1 root root 14081677 Jun 27 19:42 atop_20100627

Additional info:
Logrotate should completely ignore atop's daily rawfiles at /var/log/atop/atop_* 

/etc/cron.d/atop takes care of rotating and expiring them.

Comment 1 Brian Pitts 2010-06-28 14:42:25 UTC

*** This bug has been marked as a duplicate of bug 542598 ***


Note You need to log in before you can comment on or make changes to this bug.