Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 608594 - query about lack of EL-6 branch for perl-Module-Find
query about lack of EL-6 branch for perl-Module-Find
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: perl-Module-Find (Show other bugs)
6.0
All Linux
low Severity medium
: beta
: ---
Assigned To: perl-maint-list
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-28 04:56 EDT by Mark Chappell
Modified: 2010-09-15 02:51 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-15 02:51:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Chappell 2010-06-28 04:56:41 EDT
I'm chasing down the dependency tree for RT3 in EL-6, for some reason perl-Module-Find doesn't have an EL-6 branch.

https://koji.fedoraproject.org/koji/getfile?taskID=2273062&name=root.log

Is this because you're not interested in maintaining it any more or is there another reason?  I'm happy to (co)maintain EL branches if this would help.
Comment 1 Mark Chappell 2010-06-28 12:41:24 EDT
More confusingly, it's actually only showing up for x86_64.
Comment 3 RHEL Product and Program Management 2010-06-28 13:02:55 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 5 Matthew Booth 2010-06-30 09:11:41 EDT
Is this bug intended to be against RHEL or EPEL?
Comment 6 Mark Chappell 2010-06-30 11:10:20 EDT
Initially it was filed against the EPEL5 branch of perl-Module-Find I was confused as to why it hadn't branched from EPEL-5 into EPEL-6.

Then I found that the reason it didn't branch was because RHEL-6 includes perl-Module-Find.noarch but ONLY in the x86_64 repositories.  

Because it's a noarch package we wouldn't generally branch it for EPEL since it's in RHEL.

a) was this deliberate from ppc and i386 in RHEL 6 ?
b) any chance it could be added to the ppc/i386 branches ?
Comment 7 Mark Chappell 2010-06-30 11:16:34 EDT
"a" should read, "was this a deliberate exclusion from ppc and i386 in RHEL 6 ?"
Comment 8 Bill Nottingham 2010-06-30 12:17:14 EDT
perl-Module-Find is a build requirement of one of the only-on-x86_64 virt tools... it's essentially an implementation detail. It's intentional that it's only on the platform where it's required.

Now, we do need to find a good solution as to how to handle this between RHEL and EPEL. That's still being worked on.
Comment 9 RHEL Product and Program Management 2010-07-15 10:26:17 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 10 Marcela Mašláňová 2010-07-19 08:02:29 EDT
I suppose you should sent this request to EPEL list and find out how will be solved these issues.
Comment 11 Mark Chappell 2010-07-19 08:52:17 EDT
(In reply to comment #10)
> I suppose you should sent this request to EPEL list and find out how will be
> solved these issues.    

EPEL are basically just going to rebuild the RHEL-6 SRPMS.  Are you aware of any mechanism available for monitoring Red Hat releases for *only* certain packages, rather than all Errata?  (So we can put through the appropriate rebuilds)
Comment 12 Marcela Mašláňová 2010-07-20 03:09:09 EDT
I suppose someone working more on EPEL was generating a list of packages, which changed. Maybe spot could help?
Comment 13 Mark Chappell 2010-09-14 11:49:58 EDT
We've now generated some scripts for keeping an eye on EPEL pkgs vs RHEL pkgs so I'm happy for you to close off this ticket.

Note You need to log in before you can comment on or make changes to this bug.