Bug 608646 - virt-manager: (virt-install) will run the VM by default as " -M rhel5.4.0 " on rhel5.5 server
Summary: virt-manager: (virt-install) will run the VM by default as " -M rhel5.4.0 " o...
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager (Show other bugs)
(Show other bugs)
Version: 5.5
Hardware: All Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Cole Robinson
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-28 11:31 UTC by yeylon@redhat.com
Modified: 2016-04-18 06:33 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-29 04:49:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description yeylon@redhat.com 2010-06-28 11:31:38 UTC
Description of problem:

i've installed a VM on rhel 5.5 server using virt-install
by default the "-M" flag have "rhel5.4.0" which is not true.

the virt-install should recognize on which OS the server is running and set the flag according to the server OS.  


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

[root@green-vdsb ~]# ps -aux | grep kvm
Warning: bad syntax, perhaps a bogus '-'? See /usr/share/doc/procps-3.2.7/FAQ
root     12945 66.6  0.1 2289792 25424 ?       Sl   14:24   0:13 /usr/libexec/qemu-kvm -S -M rhel5.4.0 -m 2048 -smp 1 -name RHEVM-HA -uuid 00000000-0000-0000-0000-000000000002 -no-kvm-pit-reinjection -monitor pty -pidfile /var/run/libvirt/qemu//RHEVM-HA.pid -localtime -boot c -drive file=/dev/rhevm-cluster01/rhev-image,if=ide,index=0,boot=on,cache=none -drive file=/home/iso/windows_server_2008_r2.iso,if=ide,media=cdrom,index=2 -net nic,macaddr=00:1a:4a:23:66:fd,vlan=0 -net tap,fd=18,script=,vlan=0,ifname=vnet0 -serial pty -parallel none -usb -usbdevice tablet -vnc 127.0.0.1:0 -k en-us
root     13015  0.0  0.0  61160   712 pts/5    R+   14:24   0:00 grep kvm

Comment 1 Yaniv Kaul 2010-06-29 04:49:39 UTC
Not a bug - management should run by default with -M 5.4, unless it knows better, to retain backward compatibility.


Note You need to log in before you can comment on or make changes to this bug.