Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 608665 - RHEL4 client rhn_check ignoring pending events on Spacewalk 1.0 server
RHEL4 client rhn_check ignoring pending events on Spacewalk 1.0 server
Status: CLOSED DEFERRED
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other (Show other bugs)
540
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Mráka
Red Hat Satellite QA List
:
Depends On:
Blocks: 462714
  Show dependency treegraph
 
Reported: 2010-06-28 08:40 EDT by Jan Hutař
Modified: 2011-04-15 12:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-15 12:23:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2010-06-28 08:40:25 EDT
Description of problem:
I have RHEL4 server registered to Spacewalk 1.0 server to a custom channel. When I schedule some action using XMLRPC or WebUI (custom errata update or package install) and call rhn_check on the client, it is not picked up. Normal up2date -u or -i works as expected.


Version-Release number of selected component (if applicable):
Server: Spacewalk 1.0
Client: up2date-4.8.1-33.el4_8.7.x86_64
        rhnlib-2.1.4-14.el4_8.noarch


How reproducible:
always (tested multiple times on 1 system)


Steps to Reproduce:
1. Register RHEL4 system to the Spacewalk 1.0 server
2. Schedule some event in the WebUI for that system
   (e.g. package uninstallation)
3. Run `rhn_check -vv` on the client


Actual results:
# rhn_check -vv
D: do_call packages.checkNeedUpdate ('rhnsd=1',)
D: local action status:  (0, 'rpm database not modified since last update (or package list recently updated)', {})


Expected results:
Action should be executed.


Additional info:
Spacewalk WebUI:
  https://<SW10>/network/systems/details/history/pending.pxt?sid=1000010084
    shows scheduled action "Package Removal scheduled by jhutar"
Client:
  # grep ID /etc/sysconfig/rhn/systemid
  <value><string>ID-1000010084</string></value>
  # grep serverURL= /etc/sysconfig/rhn/up2date
  serverURL=https://<SW10>/XMLRPC
Comment 1 Arjen Heidinga 2010-06-30 06:01:33 EDT
I had exactly this problem. 4 hours later I yelled at my PC. Colleague of mine suggested: "Maybee stupid question, but is the time set correctly?"

I checked and ntpdate returned "offset -3597.642301 sec". Crap.
Restarted spacewalk server, waited till tomcat extracted some packages, and ran rhn_check.

It works. Ergo, install ntpd. Allways.

Note You need to log in before you can comment on or make changes to this bug.