Bug 60867 - Unusual error message from eject
Unusual error message from eject
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-07 20:22 EST by Derek Tattersall
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-11 11:14:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Derek Tattersall 2002-03-07 20:22:22 EST
Description of Problem:  Ejecting /dev/cdrom with CD-1 of Hampton, the following message
is seen, then the CD ejected..
cannot open /etc/mtab.tmp (Invalid argument) - mtab not updated

Occurrs as user or root.  User is member of Wheel group.


Version-Release number of selected component (if applicable):
eject-2.0.12-4

How Reproducible:
Happens every time

Steps to Reproduce:
1. Mount a data CD (Cd 1 works)
2.  type "eject" at command prompt
3.  Observe odd output

Actual Results:


Expected Results: Probably should not umount and eject as a regular user


Additional Information:
Comment 1 Ngo Than 2002-03-11 09:41:28 EST
eject just uses mount and umount in util-linux. It'a bug in util-linux.  
I cannot reproduce it on my machine with eject-2.0.12-4 and mount-2.11n-7.  
  
Comment 2 Elliot Lee 2002-03-11 11:11:58 EST
Can't reproduce here either. Please see if running 'umount /dev/cdrom' directly
does anything different...
Comment 3 Elliot Lee 2002-03-11 11:14:07 EST
Oh, and "Expected Results: Probably should not umount and eject as a regular
user" is an incorrect assumption, since the console user is specifically
supposed to be able to do things like this (and a bug was recently fixed that
allowed other users to do the umount...). If that is all the bug is, I can close it.
Comment 4 Derek Tattersall 2002-03-11 18:43:31 EST
Since reinstalling the system several times, the odd message no longer appears.  
Therefor, I'll close the bug as WORKSFORME and go hide my head in shame.

Note You need to log in before you can comment on or make changes to this bug.