Bug 608677 - Fault 1046: 'redstone.xmlrpc.XmlRpcFault: proxy_channel_not_found'
Fault 1046: 'redstone.xmlrpc.XmlRpcFault: proxy_channel_not_found'
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
1.0
All Linux
urgent Severity high
: ---
: ---
Assigned To: Milan Zázrivec
Red Hat Satellite QA List
:
Depends On: 521802
Blocks: space11
  Show dependency treegraph
 
Reported: 2010-06-28 09:06 EDT by Milan Zázrivec
Modified: 2010-08-19 04:24 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 521802
Environment:
Last Closed: 2010-08-19 04:24:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Zázrivec 2010-06-28 09:06:17 EDT
+++ This bug was initially created as a clone of Bug #521802 +++

Description of problem:

I have Satellite 5.3.0 GA. I have synced RHN Proxy channels from the channel dumps. I have RHEL 4 client registered to that Satellite, I have added RHN Tools channel to it, installed spacewalk-proxy-installer. Now I try to run the installer and it fails with

Fault 1046: 'redstone.xmlrpc.XmlRpcFault: proxy_channel_not_found'

Version-Release number of selected component (if applicable):

Satellite 5.3.0.
spacewalk-proxy-installer-0.5.25-18.el4sat

How reproducible:

Deterministic.

Steps to Reproduce:
1. Have Satellite 5.3.0.
2. Sync RHEL 4 base and RHN Tools and RHN Proxy channels.
3. Register client, install spacewalk-proxy-installer, run the installer.
  
Actual results:

[root@vmware146 ~]# /usr/sbin/configure-proxy.sh --answer-file=/tmp/proxy-answer.txt --non-interactive
RHN Parent [xen62.englab.brq.redhat.com]: xen62.englab.brq.redhat.com
CA Chain [/usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT]: /usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT
Proxy version to activate [5.3]: 5.3
Traceback email [jpazdziora@redhat.com]: jpazdziora@redhat.com
Use SSL [Y]: Y
HTTP Proxy []: 
Regardless of whether you enabled SSL for the connection to the Spacewalk Parent
Server, you will be prompted to generate an SSL certificate.
This SSL certificate will allow client systems to connect to this Spacewalk Proxy
securely. Refer to the Spacewalk Proxy Installation Guide for more information.
Organization [R]: R
Organization Unit [vmware146.englab.brq.redhat.com]: vmware146.englab.brq.redhat.com
Common Name [vmware146.englab.brq.redhat.com]: vmware146.englab.brq.redhat.com
City [B]: B
State []: 
Country code [CZ]: CZ
Email [jpazdziora@redhat.com]: jpazdziora@redhat.com
API version: 5.3.0

There was a problem activating the RHN Proxy entitlement:
ERROR: upon entitlement/activation attempt: unknown error - <Fault 1046: 'redstone.xmlrpc.XmlRpcFault: proxy_channel_not_found'>
Proxy activation failed! Installation interrupted.
API version: 5.3.0
RHN Proxy successfully deactivated.
[root@vmware146 ~]# 

Expected results:

Proxy activated alright.

Additional info:

The content of my /tmp/proxy-answer.txt is:

[root@vmware146 ~]# cat /tmp/proxy-answer.txt
VERSION="5.3"
RHN_PARENT="xen62.englab.brq.redhat.com"
TRACEBACK_EMAIL="jpazdziora@redhat.com"
USE_SSL="Y"
CA_CHAIN="/usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT"
HTTP_PROXY=
SSL_ORG="R"
SSL_ORGUNIT="vmware146.englab.brq.redhat.com"
SSL_COMMON="vmware146.englab.brq.redhat.com"
SSL_CITY="B"
SSL_STATE=""
SSL_COUNTRY="CZ"
SSL_EMAIL="jpazdziora@redhat.com"
INSTALL_MONITORING="n"
POPULATE_CONFIG_CHANNEL="n"
[root@vmware146 ~]# 

When I look at the Alter Channel Subscriptions page of that client machine on the WebUI of the Satellite, I can see

   Red Hat Network Proxy (v5.3 for AS v4 x86)  (100 available) 

there, with the checkbox greyed out. So I assume I have entitlements available alright.

--- Additional comment from jpazdziora@redhat.com on 2009-09-08 08:00:31 EDT ---

WebUI installation / activation worked OK on the same Satellite + client.

--- Additional comment from msuchy@redhat.com on 2009-09-08 09:11:51 EDT ---

[14:45] <mirek> adelton: it seems that channel dump do not containt that information about product name and version.  I'm going to check code now if it should contain or not.
[15:06] <mirek> adelton: I checked sputnik-prod and its dumps and it seem that neither there nor in 5.3 dumps is product version (which mean you are unable to install proxy even using those dumps), the strange part is that there is some parts code, which probably want to dump that, but it is somewhere in code later discarded.

The satellite was populated using channel dumps available on partners.r.c. I will bet that using propper sync it will work. But channel dump do not have record for table RHNCHANNELPRODUCT, which is required for RHN Proxy activation.
So this is probably bug of rhn-satellite-exporter.

--- Additional comment from jpazdziora@redhat.com on 2009-09-08 10:30:19 EDT ---

I've activated the Satellite against stage and re-run satellite-sync of the RHN Proxy channels. Now the command line installer works OK. So the issue indeed seems to be somewhere in the channel dumps.

--- Additional comment from msuchy@redhat.com on 2009-09-08 12:56:24 EDT ---

yes, indeed, now the table is corectly populated:
SQL> select * from RHNCHANNELPRODUCT;

        ID
----------
PRODUCT   
--------------------------------------------------------------------------------
VERSION                                                          B CREATED      
---------------------------------------------------------------- - ---------    
MODIFIED                                                                        
---------                                                                       
        21                                                                      
proxy                                                                           
5.3                                                              N 08-SEP-09    
08-SEP-09    


So conclusion is that live (and most probably ISS) sync will populate RHNCHANNELPRODUCT, but channel dumps not. We need to enhance rhn-satellite-exporter to export this table as well...
Comment 1 Milan Zázrivec 2010-06-28 09:12:03 EDT
spacewalk.git master: c8ddf6887e1efd21a9dca90df8e381d30a10b77c
Comment 2 Milan Zázrivec 2010-08-19 04:24:38 EDT
Spacewalk 1.1 has been released.

Note You need to log in before you can comment on or make changes to this bug.