Bug 608691 - Firefox is consuming too much memory when opening XML file
Summary: Firefox is consuming too much memory when opening XML file
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: firefox
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Martin Stransky
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-28 13:41 UTC by Karel Srot
Modified: 2010-07-23 15:15 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-23 15:15:40 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Mozilla Foundation 197956 None None None Never
Mozilla Foundation 231925 None None None Never
Mozilla Foundation 291643 None None None Never
Mozilla Foundation 526825 None None None Never

Description Karel Srot 2010-06-28 13:41:59 UTC
Description of problem:

Not sure whether this bug can be realy fixed...
Firefox is consuming too much memory when processing XML files.
Opening 2.5MB large XML file takes almost 300MB of memory.


Version-Release number of selected component (if applicable):
firefox-3.6.4-4.el6

How reproducible:
always for me

Steps to Reproduce:
1. run "top"
2. in firefox open "large" xml file, such as 
http://nest.test.redhat.com/mnt/qa/scratch/ksrot/tmp/filelists.xml (2.5MB)
or 
any other XML file, e.g. any "repodata" XML file from Fedora repository.
(Be aware that those files have almost 30MB and may make your system unsusable. Rather truncate the file first).
3. in "top" observe the amount of used memory

Actual results:
Firefox is consuming too much memory. 10MB XML file may make 2GB RAM system "unusable".

Comment 1 RHEL Product and Program Management 2010-06-28 13:43:05 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 2 Christopher Aillon 2010-07-04 18:18:24 UTC
While it does use up memory, I cannot reproduce the hang on either a baremetal T61 with 2GB RAM, or on a VM with 768 MB RAM.

Comment 3 RHEL Product and Program Management 2010-07-15 15:09:33 UTC
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Comment 4 Matěj Cepl 2010-07-19 21:51:50 UTC
(In reply to comment #2)
> While it does use up memory, I cannot reproduce the hang on either a baremetal
> T61 with 2GB RAM, or on a VM with 768 MB RAM.    

Me neither. Reporter, are you able to reproduce this even in the Safe Mode (run firefox with -safe-mode parameter)?

Comment 5 Karel Srot 2010-07-20 07:03:51 UTC
Yes, I can reproduce it in safe-mode and also even after the update to firefox-3.6.6-2.el6. When opening the linked 2.5MB XML file firefox is consuming 316MB of RAM.

Comment 6 Matěj Cepl 2010-07-20 16:53:15 UTC
(In reply to comment #5)
> Yes, I can reproduce it in safe-mode and also even after the update to
> firefox-3.6.6-2.el6. When opening the linked 2.5MB XML file firefox is
> consuming 316MB of RAM.    

yes, 300MB I can reproduce, but not system crashing. What's the RAM of your computer?

Comment 7 Karel Srot 2010-07-21 07:03:35 UTC
> yes, 300MB I can reproduce, but not system crashing. What's the RAM of your
> computer? 

Not really system crash (did I say that?). I was trying to say that opening of 30 MB XML file (such as any repodata XML from Fedora repo) in firefox may consume all your available memory. That 2.5 MB XML file is only an example (consumes 300MB). When I tried to open larger XML my system with 2 GB of memory became unsuable - took me almost 10 minutes just to switch to console, login and type "killall firefox".


Note You need to log in before you can comment on or make changes to this bug.