Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 608699 - pulp, pulp package use of --repoid is confusing to user
pulp, pulp package use of --repoid is confusing to user
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Community
Component: z_other (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Pradeep Kilambi
wes hayutin
: QA-Closed
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-28 09:53 EDT by wes hayutin
Modified: 2011-07-15 15:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-20 12:11:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2010-06-28 09:53:07 EDT
Description of problem:

repoid is confusing because the term is not used w/ a repo list. We may want to switch it to label or something

[root@localhost httpd]# pulp package info -p zsh --repoid=f12-i386
Package [zsh] not found in repo [f12-i386]

[root@localhost httpd]# pulp repo list
+-------------------------------------------+
    List of Available Repositories 
+-------------------------------------------+

Label              	f12-i386                 
Name               	f12-i386                 
Feed               	{'url': 'http://download.devel.redhat.com/released/F-12/GOLD/Fedora/i386/os/', 'type': 'yum', 'supported_types': ['yum', 'local', 'rhn']}
Arch               	i386                     
Packages           	0                        
Package Categories 	[]                       
Package Groups     	0
Comment 1 wes hayutin 2010-06-28 10:05:20 EDT
Usage: pulp package info [OPTIONS]

Options:
  -h, --help            show this help message and exit
  -p NAME, --pkgname=NAME
                        Repository Label
  --repoid=REPOID       Repository Label
Comment 2 Preethi Thomas 2010-10-20 12:11:24 EDT
Closed after review.

Note You need to log in before you can comment on or make changes to this bug.