Bug 608702 - Blender - no menus
Summary: Blender - no menus
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-28 14:04 UTC by Richard W.M. Jones
Modified: 2010-08-10 17:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-10 17:11:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xdpyinfo output (9.58 KB, text/plain)
2010-08-10 15:44 UTC, Richard W.M. Jones
no flags Details
glxinfo output (10.38 KB, text/plain)
2010-08-10 15:44 UTC, Richard W.M. Jones
no flags Details
Xorg logfile (68.57 KB, text/plain)
2010-08-10 15:45 UTC, Richard W.M. Jones
no flags Details

Description Richard W.M. Jones 2010-06-28 14:04:23 UTC
Description of problem:

I'm pretty certain the last time I used Blender that I should
be able to start blender and press the space bar and have a
menu appear.  (Or Shift A).  However whatever I try I cannot
get any menu to appear.

Also (maybe related) the File / Add / Timeline / Game / Render
/ Help menus(?) along the top of the screen were added since I
used Blender last, but these menus or buttons or whatever they
are do absolutely nothing, no matter which button I used to click
them.

Version-Release number of selected component (if applicable):

blender-2.49b-9.fc14.i686

How reproducible:

Always.

Steps to Reproduce:
1. Run blender.
2. Press space bar or Shift+A.
3.
  
Actual results:

Nothing happens.

Expected results:

Menu should open.

Additional info:

Makes it next to impossible to use Blender for anything.

Key bindings in general appear to be working.  eg. I can use
R to rotate an object.

Comment 1 Nicolas Chauvet (kwizart) 2010-07-13 16:56:05 UTC
This works for me on F-13 x86_64 despite I need to have the mouse in the space view in order to have it to work.

So far, only the viewport shading (z shortcut) seems to have effects without needing the mouse in the space view.

Comment 2 Bug Zapper 2010-07-30 12:16:32 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 3 Richard W.M. Jones 2010-08-10 15:42:55 UTC
Following the suggestion here:
  http://www.linuxquestions.org/questions/slackware-14/intalled-blender-runs-ok-but-no-menus-visible-786260/
I set the following variable which fixed the problem:
  export BLENDER_FORCE_SWAPBUFFERS=1

So I'm forced to conclude this is some sort of X.org /
GLX / driver issue.

Reassigning to X.org component.

Comment 4 Richard W.M. Jones 2010-08-10 15:44:16 UTC
Created attachment 437929 [details]
xdpyinfo output

Comment 5 Richard W.M. Jones 2010-08-10 15:44:40 UTC
Created attachment 437930 [details]
glxinfo output

Comment 6 Richard W.M. Jones 2010-08-10 15:45:52 UTC
Created attachment 437931 [details]
Xorg logfile

Comment 7 Richard W.M. Jones 2010-08-10 17:11:34 UTC
Sorry everyone, false alarm.  I have rechecked this after
updating my X.org to Rawhide, and it now works without
requiring the environment variable.  Therefore I am
closing this bug.


Note You need to log in before you can comment on or make changes to this bug.