Bug 60875 - Fails to rebuild with autoconf-2.52
Fails to rebuild with autoconf-2.52
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: mutt (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-07 21:59 EST by Enrico Scholz
Modified: 2014-03-16 22:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-13 09:59:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix (428 bytes, patch)
2002-03-07 22:00 EST, Enrico Scholz
no flags Details | Diff

  None (edit)
Description Enrico Scholz 2002-03-07 21:59:27 EST
Description of Problem:

Rebuild of mutt fails with:

| $ rpm --rebuild mutt-1.2.5.1-2.src.rpm
| ...
| checking return type of signal handlers... void
| checking for sig_atomic_t in signal.h... ./configure: line 4477: syntax error
near unexpected token `done'
| ./configure: line 4477: `done'
| error: Bad exit status from /var/tmp/rpm-tmp.70356 (%build)
|     Bad exit status from /var/tmp/rpm-tmp.70356 (%build)

which is caused by an underquoting in configure.in. I will attach a patch fixing it.


Version-Release number of selected component (if applicable):

mutt-1.2.5.1-2.src.rpm
autoconf-2.52-7
automake-1.5-8
Comment 1 Enrico Scholz 2002-03-07 22:00:16 EST
Created attachment 47860 [details]
Fix
Comment 2 Bill Nottingham 2004-08-13 09:59:47 EDT
This should work with current builds.

Note You need to log in before you can comment on or make changes to this bug.