Bug 60878 - sendmail and postfix both installed
sendmail and postfix both installed
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: chkconfig (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-08 00:52 EST by Chris Ricker
Modified: 2014-03-16 22:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-08 13:36:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2002-03-08 00:52:06 EST
(sorry if this is a repeat; I thought I saw a similar bug during beta1, but now
I can't find the bug number).

During install, I selected postfix.  I meant to deselect sendmail, but must have
overlooked it when wading through the individual package list....  After reboot,
both postfix and sendmail were on the box, and both were running (a setup which
just plain Doesn't Work).

I'm not sure if this should be fixed in anaconda, or in the respective sendmail
and postfix .SPEC files, but those two packages need to conflict with each
other, and should not be simultaneously installed.
Comment 1 Jeremy Katz 2002-03-08 10:54:22 EST
They don't conflict and should be able to be simultaneously installed, but their
alternatives magic isn't quite right yet.  Assigning to Bill and moving to
chkconfig since that's where the alternatives stuff is and I know Bill was
working on some things related to this last night
Comment 2 Chris Ricker 2002-03-08 13:36:43 EST
Ah, so the idea will be that chkconfig magically takes care of /etc/alternative
symlinks whenever switching between MTAs?

At any rate, here's exactly what I saw after install.  postfix processes were
running (nqmgr, master, etc.), and sendmail -q1h -mumble was also running.... 
At that point, when I tried sending mail, it died a horrible and painful death
trying to connect to an SMTP server (which I didn't find too surprising, given
that both MTAs were running ;-).

However, both sendmail and postfix rpms are buggy (postfix just doesn't work out
of the box currently, since the chroot is messed up, and sendmail's
modifications of /etc/alternatives appear to be buggy, judging by the errors I
got when I tried to uninstall it), so I'm not sure if mail not working was due
to dueling mtas, or to the fact that neither mta currently works w/o
modification....

I'll try to do another install later today and get more info.
Comment 3 Bill Nottingham 2002-03-08 14:49:12 EST
Correct; starting with chkconfig-1.3.0, alternatives takes a --initscript
option; it then handles disabling/enabling whichever ones it needs to. Of
course, this isn't in the beta. Marking resolved in rawhide; other issues with
the MTAs not actually working may still be a problem.

Note You need to log in before you can comment on or make changes to this bug.