Bug 6088 - PCMCIA Cards not recognized
PCMCIA Cards not recognized
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
: 7570 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-19 12:51 EDT by g_caceres
Modified: 2008-05-01 11:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-04 09:48:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description g_caceres 1999-10-19 12:51:56 EDT
I have a Toshiba Satellite 4010CDS and at boot ttime the
PCMCIA cards are not recognized.

In order to make them work I need to remove and put them
againg and then it works.

I have 2 cards... one is a Noteworthy 56k Modem (that comes
with the computer as default) and a Linksys Ethernet card
10/100 Fast ethernet

I used to have redhat 6.0 on the same computer and it didn't
have this problem with the same configuration (hardware)

------- Additional Comments From   10/23/99 15:40 -------
I have a similar problem on a Toshiba Satellite 225CDS.  Under Redhat
6.0 (both 2.2.5-15 and 2.2.5-22 kernels), my PCMCIA cards were
recognized properly.

However, under 2.2.12-20, the cards are not recognized properly.  Here
are two sections of /var/log/messages -- the first one was under
kernel 2.2.5-22, and the second one under 2.2.12-20 (in both cases,
Socket 0 has a modem, and Socket 1 has a 10Base-T Ethernet):
------------2.2.5-22--------------
Sep 13 13:54:54 lowen pcmcia: Starting PCMCIA services:
Sep 13 13:54:55 lowen pcmcia:  modules
Sep 13 13:54:55 lowen kernel: Linux PCMCIA Card Services 3.0.9
Sep 13 13:54:55 lowen kernel:   kernel build: 2.2.5-22 #1 Wed Jun 2
08:45:51 EDT 1999
Sep 13 13:54:55 lowen kernel:   options:  [pci] [cardbus] [apm]
Sep 13 13:54:55 lowen kernel: Intel PCIC probe:
Sep 13 13:54:55 lowen kernel:   Intel i82365sl B step ISA-to-PCMCIA at
port 0x3e0 ofs 0x00, 2 sockets
Sep 13 13:54:55 lowen kernel:     host opts [0]: none
Sep 13 13:54:55 lowen kernel:     host opts [1]: none
Sep 13 13:54:55 lowen kernel:     ISA irqs (scanned) = 3,4,5,7,9,10,12
status change on irq 10
Sep 13 13:54:55 lowen pcmcia:  cardmgr.
Sep 13 13:54:55 lowen cardmgr[322]: starting, version is 3.0.9
Sep 13 13:54:55 lowen cardmgr[322]: watching 2 sockets
Sep 13 13:54:55 lowen kernel: cs: IO port probe 0x1000-0x17ff: clean.
Sep 13 13:54:55 lowen kernel: cs: IO port probe 0x0100-0x04ff:
excluding 0x220-0x22f 0x320-0x337 0x378-0x37f 0x388-0x38f 0x480-0x48f
0x4d0-0x4d7
Sep 13 13:54:55 lowen kernel: cs: IO port probe 0x0a00-0x0aff: clean.
Sep 13 13:54:55 lowen cardmgr[322]: initializing socket 0
Sep 13 13:54:55 lowen kernel: cs: memory probe 0x0d0000-0x0dffff:
clean.
Sep 13 13:54:55 lowen cardmgr[322]: socket 0: Serial or Modem
Sep 13 13:54:55 lowen rc: Starting pcmcia succeeded
Sep 13 13:54:56 lowen cardmgr[322]: executing: 'insmod
/lib/modules/2.2.5-22/pcmcia/serial_cs.o'
Sep 13 13:54:56 lowen kernel: tty01 at 0x02f8 (irq = 3) is a 16550A
Sep 13 13:54:56 lowen cardmgr[322]: executing: './serial start ttyS1'
Sep 13 13:54:56 lowen lpd: lpd startup succeeded
Sep 13 13:54:56 lowen cardmgr[322]: initializing socket 1
Sep 13 13:54:56 lowen cardmgr[322]: socket 1: Megahertz CC10BT/2
Ethernet
Sep 13 13:54:56 lowen keytable: Loading keymap:
Sep 13 13:54:56 lowen cardmgr[322]: executing: 'insmod
/lib/modules/2.2.5-22/pcmcia/smc91c92_cs.o'
Sep 13 13:54:56 lowen kernel: eth0: smc91c94: port 0x100, irq 5,
10baseT port, hw_addr 00:00:86:19:22:E4
Sep 13 13:54:56 lowen cardmgr[322]: executing: './network start eth0'
----------------------------------------------------

------------2.2.12-20----------------
Oct 23 15:08:35 lowen pcmcia: Starting PCMCIA services:
Oct 23 15:08:35 lowen pcmcia:  modules
Oct 23 15:08:35 lowen kernel: Linux PCMCIA Card Services 3.0.14
Oct 23 15:08:35 lowen kernel:   kernel build: 2.2.12-20 #1 Mon Sep 27
10:25:54 EDT 1999
Oct 23 15:08:35 lowen kernel:   options:  [pci] [cardbus] [apm]
Oct 23 15:08:36 lowen kernel: Intel PCIC probe:
Oct 23 15:08:36 lowen kernel:   Intel i82365sl B step ISA-to-PCMCIA at
port 0x3e0 ofs 0x00, 2 sockets
Oct 23 15:08:36 lowen kernel:     host opts [0]: none
Oct 23 15:08:36 lowen kernel:     host opts [1]: none
Oct 23 15:08:36 lowen kernel:     ISA irqs (scanned) = 3,4,5,7,9,10,12
status change on irq 10
Oct 23 15:08:36 lowen pcmcia:  cardmgr.
Oct 23 15:08:36 lowen cardmgr[338]: starting, version is 3.0.14
Oct 23 15:08:36 lowen cardmgr[338]: watching 2 sockets
Oct 23 15:08:36 lowen kernel: cs: IO port probe 0x1000-0x17ff: clean.
Oct 23 15:08:36 lowen kernel: cs: IO port probe 0x0100-0x04ff:
excluding 0x220-0x22f 0x320-0x337 0x378-0x37f 0x388-0x38f 0x480-0x48f
0x4d0-0x4d7
Oct 23 15:08:36 lowen kernel: cs: IO port probe 0x0a00-0x0aff: clean.
Oct 23 15:08:36 lowen cardmgr[338]: initializing socket 0
Oct 23 15:08:36 lowen kernel: cs: memory probe 0x0d0000-0x0dffff:
clean.
Oct 23 15:08:36 lowen cardmgr[338]: socket 0: SVEC 10/100 Fast
Ethernet
Oct 23 15:08:36 lowen rc: Starting pcmcia succeeded
Oct 23 15:08:36 lowen cardmgr[338]: executing: 'insmod
/lib/modules/2.2.12-20/pcmcia/cb_enabler.o'
Oct 23 15:08:36 lowen cardmgr[338]: executing: 'insmod
/lib/modules/2.2.12-20/pcmcia/tulip_cb.o'
Oct 23 15:08:37 lowen kernel: Unable to handle kernel NULL pointer
dereference at virtual address 00000004
Oct 23 15:08:37 lowen kernel: current->tss.cr3 = 01d3d000, %cr3 =
01d3d000
Oct 23 15:08:37 lowen kernel: *pde = 00000000
Oct 23 15:08:37 lowen kernel: Oops: 0000
[kernel oops here is a red herring, since there IS no tulip ethernet
card in the system]
------------------------------------

Hope this helps find the problem.

Lamar Owen
WGCR Internet Radio
Comment 1 g_caceres 1999-10-26 12:54:59 EDT
This is my /var/log/messages file... with the toshiba 4010CDS

Oct 26 17:40:36 localhost pcmcia: Starting PCMCIA services:
Oct 26 17:40:36 localhost pcmcia:  modules
Oct 26 17:40:36 localhost kernel: Linux PCMCIA Card Services 3.0.14
Oct 26 17:40:36 localhost kernel:   kernel build: 2.2.12-20 #1 Mon Sep
27 10:40:35 EDT 1999
Oct 26 17:40:36 localhost kernel:   options:  [pci] [cardbus] [apm]
Oct 26 17:40:36 localhost kernel: Intel PCIC probe:
Oct 26 17:40:36 localhost kernel:   Toshiba ToPIC97 PCI-to-CardBus at
bus 0 slot 2, mem 0x68000000, 2 sockets
Oct 26 17:40:36 localhost kernel:     host opts [0]: [slot 0xf0] [ccr
0x10] [cdr 0x86] [rcr 0x02] [no pci irq] [lat 168/176] [bus 20/20]
Oct 26 17:40:36 localhost kernel:     host opts [1]: [slot 0xf0] [ccr
0x20] [cdr 0x86] [rcr 0x02] [no pci irq] [lat 168/176] [bus 21/21]
Oct 26 17:40:36 localhost kernel:     ISA irqs (default) =
3,4,7,9,10,12 polling interval = 1000 ms
Oct 26 17:40:36 localhost pcmcia:  cardmgr.
Oct 26 17:40:36 localhost cardmgr[371]: starting, version is 3.0.14
Oct 26 17:40:36 localhost cardmgr[371]: watching 2 sockets
Oct 26 17:40:36 localhost kernel: cs: IO port probe 0x1000-0x17ff:
clean.
Oct 26 17:40:36 localhost kernel: cs: IO port probe 0x0100-0x04ff:
excluding 0x220-0x22f 0x378-0x37f 0x4d0-0x4d7
Oct 26 17:40:36 localhost kernel: cs: IO port probe 0x0a00-0x0aff:
clean.
Oct 26 17:40:36 localhost cardmgr[371]: initializing socket 0
Oct 26 17:40:36 localhost kernel: cs: memory probe 0x0d0000-0x0dffff:
excluding 0xd0000-0xdffff
Oct 26 17:40:36 localhost kernel: cs: memory probe 0x0c0000-0x0cffff:
excluding 0xc0000-0xcffff
Oct 26 17:40:36 localhost cardmgr[371]: socket 0: Anonymous Memory
Oct 26 17:40:37 localhost rc: Starting pcmcia succeeded
Oct 26 17:40:37 localhost cardmgr[371]: executing: 'insmod
/lib/modules/2.2.12-20/pcmcia/memory_cs.o'
Oct 26 17:40:37 localhost kernel: memory_cs: mem0: anonymous: unknown
size
Oct 26 17:40:37 localhost cardmgr[371]: executing: './memory start
mem0'
Oct 26 17:40:37 localhost inet: inetd startup succeeded
Oct 26 17:40:37 localhost cardmgr[371]: initializing socket 1
Oct 26 17:40:37 localhost cardmgr[371]: socket 1: Anonymous Memory
Oct 26 17:40:37 localhost lpd: lpd startup succeeded
Oct 26 17:40:37 localhost cardmgr[371]: executing: './memory start
mem1'
Oct 26 17:40:37 localhost kernel: memory_cs: mem1: anonymous: unknown
size
Comment 2 Edward Schlunder 1999-11-13 19:59:59 EST
The <A HREF="http://pcmcia.sourceforge.org/ftp/CHANGES">PCMCIA Changelog</A>
shows numerous updates being made for Toshiba laptops. Also, for Lamar's
problem, PCMCIA release 3.1.0 changelog mentions "Commented out a couple of
bogus config file entries that were causing the tulip_cb driver to load for
various 16-bit cards." which sounds like exactly the problem you're
describing.<BR><BR>
Perhaps upgrading to a newer PCMCIA package will help.
Comment 3 Ron Fox 1999-11-17 10:20:59 EST
I've found a simple solution to the same problem on a Toshiba 335CDS.

Symptoms are as described by others:
  1) 2 PCMCIA cards:
       3Com EtherLink III 3C589B
       Xircom Credit Card Modem 56T
  2) Autodetected properly at boot under RH6.0
  3) Failed to be properly identified at boot 100% of time under RH6.1
     until the cards were removed and reinserted.

I found suspect entries in /var/log/messages under RH6.1 of the form:
{date}{time}{hostname} cardmgr [{pid}]: socket {n}: Anonymous memory

Solution (100% success for me):
Change PC card controller mode from AutoSelected to CardBus/16bit or
PCIC compatible.

Procedure:
1) Boot to Win95 (sadly)
2) Start -> Programs -> Toshiba Utilities -> Hardware Setup
3) "Hardware Configuration" dialog, click "Hardware Options..." button
4) "Hardware Configuration Options" dialog, click "PC Card" tab
5) Among "PC Card Controller Mode" radio buttons, changed selection
   from "Auto Selected" to "CardBus/16bit" or "PCIC Compatible"
6) Click "OK" button and allow reboot as suggested
7) Linux comes up with proper detection of both cards (yah!)

I'm attaching the /var/log/messages entries at boot for 4 combinations
of kernel and PC card controller mode in hopes that they will help others
who have the same problem:
   RH   PC card controller mode  Intel PCIC probe ID   Auto Detection
   ===  =======================  ===================   ==============
1) 6.0  Auto Selected            Toshiba ToPIC97             OK
2) 6.1  Auto Selected            Toshiba ToPIC97           FAILS
3) 6.1  CardBus/16bit            Toshiba ToPIC95-B           OK
4) 6.1  PCIC compatible          Intel i82365sl B            OK

---------------- (1) RH6.0 AutoSelected mode follows --------------------
Nov  7 17:49:42 makamai kernel: Linux PCMCIA Card Services 3.0.9
Nov  7 17:49:42 makamai kernel:   kernel build: 2.2.5-15 #1 Mon Apr 19 22:21:09
EDT 1999
Nov  7 17:49:42 makamai kernel:   options:  [pci] [cardbus] [apm]
Nov  7 17:49:42 makamai kernel: Intel PCIC probe:
Nov  7 17:49:42 makamai kernel:   Toshiba ToPIC97 PCI-to-CardBus at bus 0 slot
19, mem 0x68000000, 2 sockets
Nov  7 17:49:42 makamai kernel:     host opts [0]: [slot 0xf0] [ccr 0x10] [cdr
0x86] [rcr 0x02] [no pci irq] [lat 168/176] [bus 20/20]
Nov  7 17:49:42 makamai kernel:     host opts [1]: [slot 0xf0] [ccr 0x10] [cdr
0x86] [rcr 0x02] [no pci irq] [lat 168/176] [bus 21/21]
Nov  7 17:49:42 makamai kernel:     ISA irqs (default) = 3,4,7,9,10,12 polling
interval = 1000 ms
Nov  7 17:49:43 makamai kernel: cs: IO port probe 0x1000-0x17ff: clean.
Nov  7 17:49:43 makamai kernel: cs: IO port probe 0x0100-0x04ff: excluding
0x220-0x22f 0x378-0x37f 0x480-0x48f 0x4d0-0x4d7
Nov  7 17:49:42 makamai crond: crond startup succeeded
Nov  7 07:49:32 makamai rc.sysinit: Turning on user and group quotas for local
filesystems succeeded
Nov  7 17:49:34 makamai date: Sun Nov  7 17:49:34 HST 1999
Nov  7 17:49:34 makamai rc.sysinit: Setting clock : Sun Nov  7 17:49:34 HST 1999
succeeded
Nov  7 17:49:34 makamai rc.sysinit: Enabling swap space succeeded
Nov  7 17:49:34 makamai init: Entering runlevel: 3
Nov  7 17:49:35 makamai apmd[115]: Version 3.0beta4 (APM BIOS 1.2, Linux driver
1.9)
Nov  7 17:49:35 makamai apmd: apmd startup succeeded
Nov  7 17:49:39 makamai network: Bringing up interface lo succeeded
Nov  7 17:49:39 makamai insmod: /lib/modules/2.2.5-15/net/3c59x.o: init_module:
Device or resource busy
Nov  7 17:49:39 makamai ifup: Delaying eth0 initialization.
Nov  7 17:49:39 makamai network: Bringing up interface eth0 failed
Nov  7 17:49:39 makamai network: Bringing up interface ppp0 succeeded
Nov  7 17:49:39 makamai netfs: Mounting other filesystems succeeded
Nov  7 17:49:40 makamai random: Initializing random number generator succeeded
Nov  7 17:49:43 makamai kernel: cs: IO port probe 0x0a00-0x0aff: clean.
Nov  7 17:49:43 makamai kernel: cs: memory probe 0x0d0000-0x0dffff: clean.
Nov  7 17:49:43 makamai kernel: tty03 at 0x02e8 (irq = 3) is a 16550A
Nov  7 17:49:44 makamai kernel: eth0: 3Com 3c589, port 0x300, irq 9, Auto port,
hw_addr 00:20:AF:85:B2:D1
Nov  7 17:49:42 makamai pcmcia: Starting PCMCIA services:
Nov  7 17:49:42 makamai pcmcia:  modules
Nov  7 17:49:42 makamai pcmcia:  cardmgr.
Nov  7 17:49:42 makamai cardmgr[329]: starting, version is 3.0.9
Nov  7 17:49:43 makamai cardmgr[329]: watching 2 sockets
Nov  7 17:49:43 makamai cardmgr[329]: initializing socket 0
Nov  7 17:49:43 makamai cardmgr[329]: socket 0: Serial or Modem
Nov  7 17:49:43 makamai cardmgr[329]: executing: 'insmod
/lib/modules/2.2.5-15/pcmcia/serial_cs.o'
Nov  7 17:49:43 makamai cardmgr[329]: executing: './serial start ttyS3'
Nov  7 17:49:44 makamai cardmgr[329]: initializing socket 1
Nov  7 17:49:44 makamai cardmgr[329]: socket 1: 3Com 3c589 Ethernet
Nov  7 17:49:44 makamai cardmgr[329]: executing: 'insmod
/lib/modules/2.2.5-15/pcmcia/3c589_cs.o'
Nov  7 17:49:44 makamai cardmgr[329]: executing: './network start eth0'
Nov  7 17:49:43 makamai rc: Starting pcmcia succeeded
---------------- (2) RH6.1 AutoSelected mode follows --------------------
Nov 14 01:42:23 makamai pcmcia: Starting PCMCIA services:
Nov 14 01:42:23 makamai pcmcia:  modules
Nov 14 01:42:23 makamai kernel: Linux PCMCIA Card Services 3.0.14
Nov 14 01:42:23 makamai kernel:   kernel build: 2.2.12-20 #1 Mon Sep 27 10:25:54
EDT 1999
Nov 14 01:42:23 makamai kernel:   options:  [pci] [cardbus] [apm]
Nov 14 01:42:23 makamai kernel: Intel PCIC probe:
Nov 14 01:42:23 makamai kernel:   Toshiba ToPIC97 PCI-to-CardBus at bus 0 slot
19, mem 0x68000000, 2 sockets
Nov 14 01:42:23 makamai kernel:     host opts [0]: [slot 0xf0] [ccr 0x10] [cdr
0x86] [rcr 0x02] [no pci irq] [lat 168/176] [bus 20/20]
Nov 14 01:42:23 makamai kernel:     host opts [1]: [slot 0xf0] [ccr 0x20] [cdr
0x86] [rcr 0x02] [no pci irq] [lat 168/176] [bus 21/21]
Nov 14 01:42:23 makamai kernel:     ISA irqs (default) = 3,4,7,9,10,12 polling
interval = 1000 ms
Nov 14 01:42:23 makamai pcmcia:  cardmgr.
Nov 14 01:42:23 makamai cardmgr[382]: starting, version is 3.0.14
Nov 14 01:42:23 makamai rc: Starting pcmcia succeeded
Nov 14 01:42:24 makamai cardmgr[382]: watching 2 sockets
Nov 14 01:42:24 makamai kernel: cs: IO port probe 0x1000-0x17ff: clean.
Nov 14 01:42:24 makamai kernel: cs: IO port probe 0x0100-0x04ff: excluding
0x220-0x22f 0x378-0x37f 0x480-0x48f 0x4d0-0x4d7
Nov 14 01:42:24 makamai kernel: cs: IO port probe 0x0a00-0x0aff: clean.
Nov 14 01:42:24 makamai cardmgr[382]: initializing socket 0
Nov 14 01:42:24 makamai kernel: cs: memory probe 0x0d0000-0x0dffff: excluding
0xd0000-0xdffff
Nov 14 01:42:24 makamai kernel: cs: memory probe 0x0c0000-0x0cffff: excluding
0xc0000-0xcffff
Nov 14 01:42:24 makamai cardmgr[382]: socket 0: Anonymous Memory
Nov 14 01:42:24 makamai cardmgr[382]: executing: 'insmod
/lib/modules/2.2.12-20/pcmcia/memory_cs.o'
Nov 14 01:42:24 makamai kernel: memory_cs: mem0: anonymous: unknown size
Nov 14 01:42:24 makamai cardmgr[382]: executing: './memory start mem0'
Nov 14 01:42:24 makamai inet: inetd startup succeeded
Nov 14 01:42:24 makamai sshd: Starting sshd:
Nov 14 01:42:25 makamai cardmgr[382]: initializing socket 1
Nov 14 01:42:25 makamai cardmgr[382]: socket 1: Anonymous Memory
Nov 14 01:42:25 makamai cardmgr[382]: executing: './memory start mem1'
Nov 14 01:42:25 makamai kernel: memory_cs: mem1: anonymous: unknown size
---------------- (3) RH6.1 CardBus/16bit mode follows -------------------
Nov 14 22:53:35 makamai pcmcia: Starting PCMCIA services:
Nov 14 22:53:35 makamai pcmcia:  modules
Nov 14 22:53:35 makamai kernel: Linux PCMCIA Card Services 3.0.14
Nov 14 22:53:35 makamai kernel:   kernel build: 2.2.12-20 #1 Mon Sep 27 10:25:54
EDT 1999
Nov 14 22:53:35 makamai kernel:   options:  [pci] [cardbus] [apm]
Nov 14 22:53:35 makamai kernel: Intel PCIC probe:
Nov 14 22:53:35 makamai kernel:   Toshiba ToPIC95-B PCI-to-CardBus at bus 0 slot
19, mem 0x68000000, 2 sockets
Nov 14 22:53:35 makamai kernel:     host opts [0]: [slot 0xf0] [ccr 0x10] [cdr
0x86] [rcr 0x02] [no pci irq] [lat 168/176] [bus 20/20]
Nov 14 22:53:35 makamai kernel:     host opts [1]: [slot 0xf0] [ccr 0x20] [cdr
0x86] [rcr 0x02] [no pci irq] [lat 168/176] [bus 21/21]
Nov 14 22:53:35 makamai kernel:     ISA irqs (default) = 3,4,7,9,10,12 polling
interval = 1000 ms
Nov 14 22:53:35 makamai pcmcia:  cardmgr.
Nov 14 22:53:36 makamai cardmgr[387]: starting, version is 3.0.14
Nov 14 22:53:36 makamai cardmgr[387]: watching 2 sockets
Nov 14 22:53:36 makamai kernel: cs: IO port probe 0x1000-0x17ff: clean.
Nov 14 22:53:36 makamai kernel: cs: IO port probe 0x0100-0x04ff: excluding
0x220-0x22f 0x378-0x37f 0x480-0x48f 0x4d0-0x4d7
Nov 14 22:53:36 makamai kernel: cs: IO port probe 0x0a00-0x0aff: clean.
Nov 14 22:53:36 makamai cardmgr[387]: initializing socket 0
Nov 14 22:53:36 makamai kernel: cs: memory probe 0x0d0000-0x0dffff: clean.
Nov 14 22:53:36 makamai cardmgr[387]: socket 0: Serial or Modem
Nov 14 22:53:36 makamai rc: Starting pcmcia succeeded
Nov 14 22:53:36 makamai cardmgr[387]: executing: 'insmod
/lib/modules/2.2.12-20/pcmcia/serial_cs.o'
Nov 14 22:53:36 makamai kernel: tty03 at 0x02e8 (irq = 3) is a 16550A
Nov 14 22:53:36 makamai cardmgr[387]: executing: './serial start ttyS3'
Nov 14 22:53:37 makamai inet: inetd startup succeeded
Nov 14 22:53:37 makamai sshd: Starting sshd:
Nov 14 22:53:37 makamai cardmgr[387]: initializing socket 1
Nov 14 22:53:37 makamai cardmgr[387]: socket 1: 3Com 3c589 Ethernet
Nov 14 22:53:37 makamai cardmgr[387]: executing: 'insmod
/lib/modules/2.2.12-20/pcmcia/3c589_cs.o'
Nov 14 22:53:37 makamai kernel: eth0: 3Com 3c589, io 0x300, irq 9, hw_addr
00:20:AF:85:B2:D1
Nov 14 22:53:37 makamai kernel:   8K FIFO split 5:3 Rx:Tx, auto xcvr
Nov 14 22:53:37 makamai cardmgr[387]: executing: './network start eth0'
---------------- (4) RH6.1 PCIC compatible mode follows -----------------
Nov 17 03:42:16 makamai pcmcia: Starting PCMCIA services:
Nov 17 03:42:16 makamai pcmcia:  modules
Nov 17 03:42:16 makamai kernel: Linux PCMCIA Card Services 3.0.14
Nov 17 03:42:16 makamai kernel:   kernel build: 2.2.12-20 #1 Mon Sep 27 10:25:54
EDT 1999
Nov 17 03:42:16 makamai kernel:   options:  [pci] [cardbus] [apm]
Nov 17 03:42:16 makamai kernel: Intel PCIC probe:
Nov 17 03:42:16 makamai kernel:   Intel i82365sl B step ISA-to-PCMCIA at port
0x3e0 ofs 0x00, 2 sockets
Nov 17 03:42:16 makamai kernel:     host opts [0]: none
Nov 17 03:42:16 makamai kernel:     host opts [1]: none
Nov 17 03:42:16 makamai kernel:     ISA irqs (scanned) = 3,4,7,9,10,12 status
change on irq 10
Nov 17 03:42:16 makamai pcmcia:  cardmgr.
Nov 17 03:42:16 makamai cardmgr[363]: starting, version is 3.0.14
Nov 17 03:42:17 makamai rc: Starting pcmcia succeeded
Nov 17 03:42:17 makamai cardmgr[363]: watching 2 sockets
Nov 17 03:42:17 makamai kernel: cs: IO port probe 0x1000-0x17ff: clean.
Nov 17 03:42:17 makamai kernel: cs: IO port probe 0x0100-0x04ff: excluding
0x220-0x22f 0x378-0x37f 0x480-0x48f 0x4d0-0x4d7
Nov 17 03:42:17 makamai kernel: cs: IO port probe 0x0a00-0x0aff: clean.
Nov 17 03:42:17 makamai cardmgr[363]: initializing socket 0
Nov 17 03:42:17 makamai kernel: cs: memory probe 0x0d0000-0x0dffff: clean.
Nov 17 03:42:17 makamai cardmgr[363]: socket 0: Serial or Modem
Nov 17 03:42:17 makamai cardmgr[363]: executing: 'insmod
/lib/modules/2.2.12-20/pcmcia/serial_cs.o'
Nov 17 03:42:17 makamai kernel: tty03 at 0x02e8 (irq = 3) is a 16550A
Nov 17 03:42:17 makamai cardmgr[363]: executing: './serial start ttyS3'
Nov 17 03:42:17 makamai inet: inetd startup succeeded
Nov 17 03:42:18 makamai sshd: Starting sshd:
Nov 17 03:42:18 makamai cardmgr[363]: initializing socket 1
Nov 17 03:42:18 makamai cardmgr[363]: socket 1: 3Com 3c589 Ethernet
Nov 17 03:42:18 makamai cardmgr[363]: executing: 'insmod
/lib/modules/2.2.12-20/pcmcia/3c589_cs.o'
Nov 17 03:42:18 makamai kernel: eth0: 3Com 3c589, io 0x300, irq 9, hw_addr
00:20:AF:85:B2:D1
Nov 17 03:42:18 makamai kernel:   8K FIFO split 5:3 Rx:Tx, auto xcvr
Nov 17 03:42:18 makamai cardmgr[363]: executing: './network start eth0'
------------------- end of /var/log/messages entries --------------------
Comment 4 Cristian Gafton 2000-01-04 17:20:59 EST
Assigned to dledford
Comment 5 David Hinds 2000-01-10 15:42:59 EST
Most of these card identification problems with Toshiba ToPIC chipsets have been
fixed in more recent PCMCIA driver releases.  In some cases, it seems to still
make a difference if the bridge is set to "auto" mode versus "16-bit/cardbus"
mode in the BIOS setup.
Comment 6 edward.gent 2000-01-13 09:31:59 EST
Thanks for the details in this bugreport. I have a Toshiba 305CDS. I used the
work around by entering the setup screens. On the 305 you can do that by
hitting ESC on power up, it will prompt you to hit F1. I am running the Linksys
10/100 PCMCIA card, no problems now.

best regards ted
Comment 7 Bill Nottingham 2000-02-06 01:04:59 EST
*** Bug 7570 has been marked as a duplicate of this bug. ***
Comment 8 wexler 2000-04-04 09:48:59 EDT
Upgrading to pcmcia-cs-3.1.13 solved the problem for me.
Comment 9 Alan Cox 2000-08-08 09:55:34 EDT
Pinstripe beta is 3.1.18 so should also be ok. If not re-open
Comment 10 rmiddle 2000-11-06 20:08:18 EST
I still had the same problem under redhat 7.0...  Fixed outline fixed problem...  I would create a perment solution to this issues...

Note You need to log in before you can comment on or make changes to this bug.