Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 608811 - Provisioning Xen paravirt lacks virt bridge
Provisioning Xen paravirt lacks virt bridge
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Installation (Show other bugs)
1.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Justin Sherrill
Red Hat Satellite QA List
:
Depends On:
Blocks: space11
  Show dependency treegraph
 
Reported: 2010-06-28 13:38 EDT by Matt Carey
Modified: 2010-08-19 04:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-19 04:24:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xen guest lacking vif (3.37 KB, text/plain)
2010-06-28 13:38 EDT, Matt Carey
no flags Details
Xen guest cobbler modification to allow system to Kickstart (2.63 KB, text/plain)
2010-06-28 13:39 EDT, Matt Carey
no flags Details

  None (edit)
Description Matt Carey 2010-06-28 13:38:48 EDT
Created attachment 427467 [details]
Xen guest lacking vif

Description of problem: When trying to provision a Xen paravirt guest on a host it fails to create the virtual NIC interface with the guest. The Kickstart profile has the "Virtual Bridge" set to xenbr0, however that value is not getting pushed down to Cobbler when reporting the system profile leading to the Kickstart to fail due to lack of network communication to the Spacewalk server.


Version-Release number of selected component (if applicable):
Spacewalk host:
spacewalk-base-1.0.3-1.el5
spacewalk-oracle-1.0.1-1.el5
cobbler-2.0.3.1-3.el5

Xen host:
rhn-virtualization-host-5.4.11-1.el5
rhn-virtualization-common-5.4.11-1.el5
spacewalk-koan-0.2.5-1.el5
koan-1.6.6-1
xen-3.0.3-94.el5
kernel-xen-2.6.18-164.el5


How reproducible:
This bug is reproducible with every attempt to provision a Xen paravirt guest.

Steps to Reproduce:
1. Create a Kickstart profile with the following attributes:  
  Virtualization Type = Xen Para-Virtualized Guest
  Virtual Bridge: xenbr0
2. In the Systems view in the WebUI select a host that is running Xen with Provisioning/Virtualization entitlements, then navigate to Virtualization->Provisioning
3. Enter a Guest Name and choose the option to Schedule Kickstart and Finish
  
Actual results:
The Xen configuration file under /etc/xen/<Guest Name> on the Xen host contains no line with vif = [ XXXXX ] when xenbr0 is specified in the Kickstart profile.

Expected results:
The Xen para-virt guest should have a virtual NIC in the configuration file when provisioning it through Spacewalk. 

Additional info:  Attached to the bug are the configurations when provisioning the guest and a quick hack to the Cobbler system profile to get the guest functional to be Kickstarted.
Comment 1 Matt Carey 2010-06-28 13:39:40 EDT
Created attachment 427468 [details]
Xen guest cobbler modification to allow system to Kickstart
Comment 2 Ian Forde 2010-07-02 18:17:44 EDT
FYI, as discussed on the spacewalk list, this also affects KVM provisioning from Spacewalk, so it's not just an issue seen when using Xen.  The workaround works for KVM provisioning too.
Comment 3 Justin Sherrill 2010-07-06 15:02:47 EDT
fixed in:
298542194ddb81730343307acae524f57b9bb6a5

Cobbler apparently at some point broke api compatibility by making the modify-interface not work (instead modify_interface should be used).

Gonna see about backporting to 1.0.
Comment 4 Milan Zázrivec 2010-08-19 04:24:56 EDT
Spacewalk 1.1 has been released.

Note You need to log in before you can comment on or make changes to this bug.