Bug 608815 - [abrt] crash in system-config-printer-1.2.2-4.fc13: system-config-printer.py:6213:fillDownloadableDrivers:AttributeError: NewPrinterGUI instance has no attribute 'downloadable_drivers'
Summary: [abrt] crash in system-config-printer-1.2.2-4.fc13: system-config-printer.py:...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer   
(Show other bugs)
Version: 13
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:6ecb5640
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-28 17:42 UTC by Ulrich Walczak
Modified: 2010-09-15 07:17 UTC (History)
2 users (show)

Fixed In Version: system-config-printer-1.2.4-2.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-15 05:28:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (738 bytes, text/plain)
2010-06-28 17:42 UTC, Ulrich Walczak
no flags Details

Description Ulrich Walczak 2010-06-28 17:42:44 UTC
abrt 1.1.1 detected a crash.

architecture: i686
cmdline: python /usr/share/system-config-printer/system-config-printer.py
component: system-config-printer
executable: /usr/share/system-config-printer/system-config-printer.py
kernel: 2.6.33.5-124.fc13.i686.PAE
package: system-config-printer-1.2.2-4.fc13
reason: system-config-printer.py:6213:fillDownloadableDrivers:AttributeError: NewPrinterGUI instance has no attribute 'downloadable_drivers'
release: Fedora release 13 (Goddard)

backtrace
-----
system-config-printer.py:6213:fillDownloadableDrivers:AttributeError: NewPrinterGUI instance has no attribute 'downloadable_drivers'

Traceback (most recent call last):
  File "/usr/share/system-config-printer/system-config-printer.py", line 4311, in on_btnNPForward_clicked
    self.nextNPTab()
  File "/usr/share/system-config-printer/system-config-printer.py", line 4560, in nextNPTab
    self.fillDownloadableDrivers()
  File "/usr/share/system-config-printer/system-config-printer.py", line 6213, in fillDownloadableDrivers
    drivers = self.downloadable_drivers
AttributeError: NewPrinterGUI instance has no attribute 'downloadable_drivers'

Local variables in innermost frame:
self: <__main__.NewPrinterGUI instance at 0x90118ac>

Comment 1 Ulrich Walczak 2010-06-28 17:42:47 UTC
Created attachment 427471 [details]
File: backtrace

Comment 2 Jiri Popelka 2010-06-28 17:49:09 UTC
Looks like regression (bug #574562).

Comment 3 Tim Waugh 2010-06-30 16:37:54 UTC
or an incomplete fix perhaps.  The original fix was to set self.downloadable_drivers in the error return from openprinting_drivers_found().  Looking at that again now I see that it doesn't release the drivers_lock so that probably isn't how we ended up in this situation.

Maybe commit f2b33e043b8ca1cc59dd6cda15cbd94859a33d01 will fix it.

Comment 4 Fedora Update System 2010-08-26 11:53:04 UTC
system-config-printer-1.2.4-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/system-config-printer-1.2.4-1.fc13

Comment 5 Fedora Update System 2010-08-26 11:55:36 UTC
system-config-printer-1.2.4-1.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/system-config-printer-1.2.4-1.fc14

Comment 6 Fedora Update System 2010-08-26 18:35:57 UTC
system-config-printer-1.2.4-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/system-config-printer-1.2.4-1.fc14

Comment 7 Fedora Update System 2010-09-13 18:08:07 UTC
system-config-printer-1.2.4-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/system-config-printer-1.2.4-2.fc14

Comment 8 Fedora Update System 2010-09-15 05:27:44 UTC
system-config-printer-1.2.4-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2010-09-15 07:17:05 UTC
system-config-printer-1.2.4-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.