Bug 60884 - modules fail to load
modules fail to load
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks: 61901
  Show dependency treegraph
 
Reported: 2002-03-08 02:17 EST by Chris Ricker
Modified: 2007-04-18 12:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-26 11:57:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2002-03-08 02:17:59 EST
After a fresh install of beta2 on a laptop (trident cyberblade / lcd combo),
starting X produces a lot of errors.  pex5 and xie modules fail to load, due to
undefined symbols (PexExtensionInitPtr and XieInitPtr, respectively).

Similarly, the module Type1 fails to load because it does not exist.

I'm not sure if the bug is in the modules themselves, or in Xconfigurator.  The
pex5 and xie modules are part of XFree86-compat-modules, and I don't think
they're even needed / usable with XFree86 4.2.  I'm not sure what, if anything,
is supposed to supply Type1.so.

The XF86Config-4 file generated during install, however, does include:

Section "Module"
  <snip>
  Load "pex5"
  <snip>
  Load "xie"
  Load "Type1"

It looks like either Xconfigurator / anaconda is buggy for putting those modules
on the list, or the pex5 and xie modules are buggy for not loading....
Comment 1 Mike A. Harris 2002-03-11 00:39:13 EST
PEX and XIE are now obsolete, and no longer shipped.  The configuration
tools will have to be appropriately modified to no longer reference
PEX and XIE.

Type1 module is included, however Red Hat Linux does not use the X server
for serving fonts by default, we use xfs instead.  The config tools should
definitely not be loading the Type1 or freetype modules.

Good catch.
Comment 2 Chris Ricker 2002-03-11 00:44:57 EST
Also, when I was cleaning out the unneeded modules from XF86Config-4, I noticed
that pex5 was actually in there twice.  It might be a good idea to do a sort -u
on the list of modules before inserting them into the X config to prevent
duplicates like that....
Comment 3 Alexander Larsson 2002-03-11 11:08:26 EST
We're gonna get tons of problems when people upgrade since these modules were in
peoples old configurations.
Comment 4 Mike A. Harris 2002-03-12 02:07:37 EST
That may be so, however either way, XIE and PEX are no longer being
shipped, nor supported.  So the config tools need to ensure that they
do not write out lines trying to load them.  I'm not sure how to best
handle the cases where existing config files have these options enabled.

Even with the options enabled I believe, the server should start up ok,
just spewing out some errors.

Any suggestions on how to best handle this case?  We'd have to handle
both distro upgrades as well as just X upgrades, which implies that
doing it in anaconda would not completely solve the problem.  Perhaps
in one of the XFree86 %post scripts.
Comment 5 Mike A. Harris 2002-03-28 16:20:09 EST
Config tools both updated to not enable/use pex/xie now

Note You need to log in before you can comment on or make changes to this bug.