Bug 60891 - Can't install latest glib2-1.3.14-1 due to anaconda dependencies
Can't install latest glib2-1.3.14-1 due to anaconda dependencies
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: anaconda (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-08 10:28 EST by Valdis Kletnieks
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-08 10:28:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Valdis Kletnieks 2002-03-08 10:28:03 EST
Description of Problem: glib2-1.3.14-1 won't install because the latest Rawhide
versions of anaconda-7.2.91-0.200202131908, passwd-0.65-2, and usermode-1.50-2
specifically require libglib-1.3.so.13 (and associated pango and atk levels).
libuser-0.49.98-1 and authconfig-4.2.5-2, and a lot of other tools already
pre-req the glib2 1.3.14 version.

Version-Release number of selected component (if applicable):
anaconda-7.2.91-0.200202131908, passwd-0.65-2, usermode-1.50-2 

How Reproducible: 'rpm -Fv glib2-1.3.14-1'


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:
error: failed dependencies:
    libglib-1.3.so.13   is needed by usermode-1.50-2
    libglib-1.3.so.13   is needed by passwd-0.65-2
    libglib-1.3.so.13   is needed by anaconda-7.2.91-0.200202131908

Expected Results:


Additional Information: Probably just rebuilding the RPMs for anaconda passwd
and usermode so they pre-req the current glib2 tree would fix this.
Comment 1 Jeremy Katz 2002-03-08 10:51:14 EST
Rawhide is never guaranteed to be a consistent.  Will be resolved as we work
towards release.

Note You need to log in before you can comment on or make changes to this bug.