This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 608918 - 2010-06-xx live media doesn't boot with qemu -cdrom
2010-06-xx live media doesn't boot with qemu -cdrom
Status: CLOSED DUPLICATE of bug 609049
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-28 18:12 EDT by Kevin Fenzi
Modified: 2010-08-03 05:57 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-30 06:07:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kevin Fenzi 2010-06-28 18:12:15 EDT
Any of the recently nightly live media don't appear to boot correctly. 

They get a:

No root device found

Boot has failed, sleeping forever. 

I tried to poke around with rdshell and initdebug, but I wasn't sure what to look for. ;( 

I did see running the /cmdline/* scripts was giving a 'getarg' unknown error, but not sure if that was just the way I was calling it or not. 

Happy to gather more info, or you can try yourself with any of the nightly composes at: 
http://alt.fedoraproject.org/pub/alt/nightly-composes/

dracut-006-1.fc14.noarch
Comment 1 Jens Petersen 2010-06-28 19:56:17 EDT
Same here for quite a while now (since before dracut-006-1.fc14).
Comment 2 Harald Hoyer 2010-06-29 06:10:39 EDT
I guess, this is with a qemu VM.

See bug 609049 

works, if you replace root=live:CDLABEL=..." with "root=live:/dev/sr0"
Comment 3 Bruno Wolff III 2010-06-29 09:59:01 EDT
As another data point I was able to sucessfully boot both a live DVD and a live USB version of the games spin using games-i386-20100625.15.iso from the nightly compose page.
Comment 4 Jens Petersen 2010-06-29 23:58:38 EDT
(In reply to comment #2)
> works, if you replace root=live:CDLABEL=..." with "root=live:/dev/sr0"    

So it could be fixed in livecd-tools?
Comment 5 Harald Hoyer 2010-06-30 04:41:25 EDT
(In reply to comment #4)
> (In reply to comment #2)
> > works, if you replace root=live:CDLABEL=..." with "root=live:/dev/sr0"    
> 
> So it could be fixed in livecd-tools?    

no... fixing qemu would be the correct way
Comment 6 Jens Petersen 2010-06-30 05:48:14 EDT
Ok, thanks for investigating carefully.

Do we leave this open or make it a duplicate of bug 609049 then?
Will it also require changes to dracut?
Comment 7 Harald Hoyer 2010-06-30 06:07:06 EDT
(In reply to comment #6)
> Ok, thanks for investigating carefully.
> 
> Do we leave this open or make it a duplicate of bug 609049 then?

yes, maybe "duplicate" is better than "depends"

> Will it also require changes to dracut?    

No, once qemu can handle the scsi command this bug is fixed.

*** This bug has been marked as a duplicate of bug 609049 ***
Comment 8 Harald Hoyer 2010-06-30 06:08:28 EDT
Nice fix for qemu! https://bugzilla.redhat.com/show_bug.cgi?id=609049#c1
Comment 9 nucleo 2010-07-09 16:51:24 EDT
I am not sure that this is the same bug but last nightly-composes live media doesn't boot also in vmware. Parameter "root=live:/dev/sr0" doesn't help.
Here error messages what I saw:

http://img36.imageshack.us/img36/8883/boot1g.png
http://img205.imageshack.us/img205/2798/boot2.png

I also tried to write iso on USB with livecd-iso-to-disk and boot on real hardware from USB. The same result was with the same error messages.
Comment 10 Jasper O'neal Hartline 2010-08-03 05:57:05 EDT
In reply to Comment 9
That is bug 619020 which we believe has been corrected, as of August 2nd/3rd.

Note You need to log in before you can comment on or make changes to this bug.