Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 608922 - mono debuginfo files (*.mdb) sometimes mis-detected
mono debuginfo files (*.mdb) sometimes mis-detected
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: file (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Jan Kaluža
Fedora Extras Quality Assurance
:
: 608919 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-28 18:34 EDT by Christian Krause
Modified: 2010-07-07 13:54 EDT (History)
1 user (show)

See Also:
Fixed In Version: file-5.04-5.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-07 13:54:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
file to demonstrate the issue (11.90 KB, application/octet-stream)
2010-06-28 18:35 EDT, Christian Krause
no flags Details
z-machine magic entry update (1.05 KB, patch)
2010-06-29 04:33 EDT, Jan Kaluža
no flags Details | Diff

  None (edit)
Description Christian Krause 2010-06-28 18:34:56 EDT
Description of problem:
mono debuginfo files (*.mdb) are sometimes misdetected as "Infocom game data" and "file" exits with a return value != 0

Version-Release number of selected component (if applicable):
file-5.04-4.fc13.i686

How reproducible:
- the issue does not happen for all mono debuginfo files, but for some of them
- even a consecutive re-compilation will change the output of the file command
- however, if a file contains the problematic byte sequence, "file" will always file
- I have attached a file showing the problem (Banshee.Dap.MassStorage.dll.mdb)

Steps to Reproduce:
1. LANG=en_US.utf8 file Banshee.Dap.MassStorage.dll.mdb
  
Actual results:
- "Banshee.Dap.MassStorage.dll.mdb: ERROR: Infocom game data (Z-machine 20, Release 32765 / vasprintf failed (Invalid or incomplete multibyte or wide character)"
- return code != 0

Expected results:
- correct detection
- return code == 0

Additional info:
Regardless whether "file" can correctly identify a file type, I'm really surprised that just arbitrary file _content_ can lead to a non-zero return code. Would it be worth to start a discussion about this general behaviour with upstream?
Comment 1 Christian Krause 2010-06-28 18:35:37 EDT
Created attachment 427521 [details]
file to demonstrate the issue
Comment 2 Christian Krause 2010-06-28 18:38:11 EDT
*** Bug 608919 has been marked as a duplicate of this bug. ***
Comment 3 Jan Kaluža 2010-06-29 04:33:59 EDT
Created attachment 427607 [details]
z-machine magic entry update

I confirm the error. Attached patch fix that for me.
Comment 4 Fedora Update System 2010-07-01 10:31:07 EDT
file-5.04-5.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/file-5.04-5.fc13
Comment 5 Fedora Update System 2010-07-05 18:02:45 EDT
file-5.04-5.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update file'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/file-5.04-5.fc13
Comment 6 Fedora Update System 2010-07-07 13:54:00 EDT
file-5.04-5.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.