Bug 608935 - Beanstalkd user does not always get created on package install
Beanstalkd user does not always get created on package install
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: beanstalkd (Show other bugs)
el5
All Linux
low Severity high
: ---
: ---
Assigned To: Jeremy Hinegardner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-28 20:05 EDT by Tavis Aitken
Modified: 2010-07-21 16:01 EDT (History)
2 users (show)

See Also:
Fixed In Version: beanstalkd-1.4.6-2.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-21 16:01:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tavis Aitken 2010-06-28 20:05:04 EDT
Description of problem:
The beanstalkd user does not get created.

Version-Release number of selected component (if applicable):
1.4.6-1

How reproducible:
Every time

Steps to Reproduce:
1. Install the beanstalkd package
4. attempt to start the beanstalkd service 

Actual results:
Starting beanstalkd: /usr/bin/beanstalkd: beanstalkd.c:91 in su: getpwnam("beanstalkd"): No such file or directory

Expected results:
The beanstalkd service starts

Additional info:
This was on a CentOS 5.4 clean install, As well as a CentOS 5.5 clean install.
Comment 1 Tavis Aitken 2010-06-29 13:24:10 EDT
I looked up the spec file at http://cvs.fedoraproject.org/viewvc/EL-5/beanstalkd/beanstalkd.spec?revision=1.5&view=markup

On line 64 the useradd should use the -g flag to add the user to the group that was just created. 

The line would end up looking like this: 

%{_sbindir}/useradd -r -m -c "beanstalkd user" -s /bin/false \    
-d %{beanstalkd_home} -g %{beanstalkd_gropu} %{beanstalkd_user} 2>/dev/null || :
Comment 2 Jeremy Hinegardner 2010-06-30 04:26:28 EDT
Yup, I just had this happen to me today too.  It looks like the machine I tested the install on already had a beanstalkd user in it.

I'll be fixing it tomorrow and pushing through the new package ASAP.
Comment 3 Fedora Update System 2010-07-01 23:07:08 EDT
beanstalkd-1.4.6-2.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/beanstalkd-1.4.6-2.el5
Comment 4 Jeremy Hinegardner 2010-07-02 15:22:20 EDT
Tavis, if you can do a test and the bump the karma on updates this should get propagated faster.

-jeremy
Comment 5 Fedora Update System 2010-07-02 15:26:06 EDT
beanstalkd-1.4.6-2.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update beanstalkd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/beanstalkd-1.4.6-2.el5
Comment 6 Fedora Update System 2010-07-09 02:00:44 EDT
beanstalkd-1.4.6-2.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update beanstalkd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/beanstalkd-1.4.6-2.el5
Comment 7 Fedora Update System 2010-07-21 16:01:34 EDT
beanstalkd-1.4.6-2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.