Bug 608937 - Should beaker Require: python-setuptools, python-paste, and pycryptopp?
Should beaker Require: python-setuptools, python-paste, and pycryptopp?
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: python-beaker (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Kyle VanderBeek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-28 20:25 EDT by Toshio Ernie Kuratomi
Modified: 2011-09-08 03:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-08 03:46:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to use paste.util.converters instead of bundled copy (1.16 KB, patch)
2010-06-28 20:25 EDT, Toshio Ernie Kuratomi
no flags Details | Diff
use try: except to use paste.util.converters if available (2.16 KB, patch)
2010-06-28 21:05 EDT, Toshio Ernie Kuratomi
no flags Details | Diff

  None (edit)
Description Toshio Ernie Kuratomi 2010-06-28 20:25:35 EDT
Created attachment 427534 [details]
Patch to use paste.util.converters instead of bundled copy

Description of problem:
It appears that beaker imports three python libraries that aren't listed in Requires:

pycryptopp is used in beaker/crypto/pycryptopp.py (python-crypto is listed as the second choice and could be used on EPEL-5 where pycryptopp isn't yet available.

python-paste is used in beaker/middleware.py

pkg_resources (from python-setuptools) is used in beaker/cache.py

Version-Release number of selected component (if applicable):
python-beaker-1.5.3-3

Additional info:

Should be able to add something like this:

Requires: python-setuptools
Requires: python-paste
%if 0%{?fedora}
Requires: pycryptopp
%else
Requires: python-crypto
%endif

I looked into this because beaker has a verbatim copy of a file from paste:
beaker/converters.py is a copy of paste/util/converters.py

If paste is already a requirement we should submit something to upstream to use the paste version instead of a bundled copy.  I'll attach a patch that does that.
Comment 1 Luke Macken 2010-06-28 20:33:39 EDT
Adding those additional dependencies and patch is fine with me.  It is probably something we want to send upstream as well.
Comment 2 Toshio Ernie Kuratomi 2010-06-28 21:02:35 EDT
Briefly talked to Ben and he thinks being able to work without setuptools and paste installed is an advantage.  The imports are inside try: except blocks so even if the code loses some functionality, it can still work.

So I'll add pycryptopp but not the others.

Makes me wonder what to do about the one copied file.. I could either put it in a try: except or not worry about it.
Comment 3 Toshio Ernie Kuratomi 2010-06-28 21:05:33 EDT
Created attachment 427538 [details]
use try: except to use paste.util.converters if available

Here's what the patch would look like if we try paste.util.converters first and fallback to the bundled copy.  Not sure if it makes sense to apply or not.
Comment 4 Toshio Ernie Kuratomi 2010-06-29 14:11:36 EDT
I've opened a bug with the patch upstream:

http://www.bitbucket.org/bbangert/beaker/issue/54/
Comment 5 Bug Zapper 2010-07-30 08:17:24 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Toshio Ernie Kuratomi 2011-09-08 03:46:34 EDT
This is done upstream wouldn't take everything but our version is not bundling and is requiring the necessary packages.

Note You need to log in before you can comment on or make changes to this bug.