Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 608974 - openldap-clients for x86_64 pulls in a bunch of i686 packages
openldap-clients for x86_64 pulls in a bunch of i686 packages
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openldap (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Jan Zeleny
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-29 01:14 EDT by Amit Shah
Modified: 2014-01-21 18:15 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-07 06:58:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of 'yum -d 7 install openldap-clients' (68.14 KB, text/plain)
2010-06-29 08:26 EDT, Amit Shah
no flags Details
Output of 'yum -d 7 install openldap-clients' after modifying depsolve.py (68.90 KB, text/plain)
2010-06-29 12:02 EDT, Amit Shah
no flags Details

  None (edit)
Description Amit Shah 2010-06-29 01:14:58 EDT
Description of problem:

A 'yum install openldap-clients' wants to install i686 packages:

========================================================================================================================================
 Package                                Arch                       Version                            Repository                   Size
========================================================================================================================================
Installing:
 openldap-clients                       x86_64                     2.4.21-4.fc13                      fedora                      155 k
Installing for dependencies:
 cyrus-sasl-lib                         i686                       2.1.23-11.fc13                     fedora                      135 k
 db4                                    i686                       4.8.30-1.fc13                      updates                     614 k
 glibc                                  i686                       2.12-2                             updates                     4.3 M
 keyutils-libs                          i686                       1.2-6.fc12                         fedora                       18 k
 krb5-libs                              i686                       1.7.1-10.fc13                      updates                     656 k
 libcom_err                             i686                       1.41.10-6.fc13                     fedora                       34 k
 libselinux                             i686                       2.0.90-5.fc13                      fedora                      104 k
 nss-softokn-freebl                     i686                       3.12.6-3.fc13                      updates                     112 k
 openldap                               i686                       2.4.21-4.fc13                      fedora                      232 k
 openssl                                i686                       1.0.0a-1.fc13                      updates                     1.4 M
 zlib                                   i686                       1.2.3-23.fc12                      fedora                       69 k

Transaction Summary
========================================================================================================================================
Install      12 Package(s)
Upgrade       0 Package(s)
Comment 1 Jan Zeleny 2010-06-29 04:27:31 EDT
This looks more like yum issue, because there is no explicit 32bit dependency in openldap-clients. Here is a requires list for openldap-clients-2.6.21-6:

libc.so.6()(64bit)  
libc.so.6(GLIBC_2.2.5)(64bit)  
libc.so.6(GLIBC_2.3)(64bit)  
libc.so.6(GLIBC_2.3.4)(64bit)  
libc.so.6(GLIBC_2.4)(64bit)  
libcrypt.so.1()(64bit)  
libcrypto.so.10()(64bit)  
liblber-2.4.so.2()(64bit)  
libldap-2.4.so.2()(64bit)  
libresolv.so.2()(64bit)  
libsasl2.so.2()(64bit)  
libssl.so.10()(64bit)  
openldap = 2.4.21-6.fc13
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rtld(GNU_HASH)  
rpmlib(PayloadIsXz) <= 5.2-1

I'm reassigning this to yum, if this turns out to be an openldap issue after all, feel free to reassign it back.
Comment 2 seth vidal 2010-06-29 08:12:29 EDT
Can you provide the depsolve output with a yum -d 7

thanks
Comment 3 Amit Shah 2010-06-29 08:26:47 EDT
Created attachment 427664 [details]
Output of 'yum -d 7 install openldap-clients'

The output was too large to fit in the bug comment; attaching file with the debug info instead.
Comment 4 seth vidal 2010-06-29 08:42:09 EDT
Amit,
 Could you try a couple of things for me?

1. Could you grab the yum out of rawhide and run the same command and see if the output changes.

2. Could you edit /usr/lib/python2.6/site-packagesa/yum/depsolve.py 

and on line 539
insert a
print pkgresults


b/c what you're getting and what the code (and debug) says you should be getting don't match up.
Comment 5 Amit Shah 2010-06-29 12:02:38 EDT
Created attachment 427724 [details]
Output of 'yum -d 7 install openldap-clients' after modifying depsolve.py

Output of 'yum -d 7 openldap-clients' after modifying depsolve.py as requested.
Comment 6 seth vidal 2010-06-29 13:10:43 EDT
okay - after some discussion on irc here's what's going on.

Amit had a newer version of openldap.x86_64 from updates-testing installed.

so he ran: yum install openldap-clients which tries to install the older x86_64 version. It has a dep of:
openldap = 2.4.21-4.fc13

Yum goes to look for pkgs which provide that and finds:
openldap-2.4.21-4.fc13.x86_64
openldap-2.4.21-4.fc13.i686

since it has a newer ver of the .x86_64 one and the i686 one provides the requirement,it takes the i686 one.

So - if openldap had an arch-specific requirement there then yum would have simply said it cannot resolve the dep and the results would be a lot more obvious.

back over to openldap.
Comment 7 Jan Zeleny 2010-07-07 06:58:14 EDT
I'm closing this bug, because situation described in comment 6 has been created by improper installation of openldap package. If installed properly, this situation won't occur.
Comment 8 James Antill 2010-07-07 10:14:59 EDT
Jan, while I mostly agree ... you might want to change the requirement to use %{_isa}.
Comment 9 Jan Zeleny 2010-07-07 10:36:26 EDT
I'm still considering it. I'm not sure whether it's a good practice or not, because I haven't seen it in any other package yet.

Note You need to log in before you can comment on or make changes to this bug.