Bug 608977 - Java applications problem
Java applications problem
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Adel Gadllah
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-29 01:25 EDT by The Source
Modified: 2010-07-16 10:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-16 10:43:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description The Source 2010-06-29 01:25:25 EDT
Description of problem:
Many java windows that have child widgets are displayed incorrectly (like Oracle SQL developer, it's free, can be downloaded from Oracle site to test) when compiz is enabled. The child widgets are not displayed at all so the main window looks empty. If I disable compiz, widgets appear and remain visible even if compiz is enabled again but only until next app restart.

Version-Release number of selected component (if applicable):
compiz-0.8.6-1.fc13.x86_64

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Adel Gadllah 2010-07-03 08:46:47 EDT
(In reply to comment #0)
> Description of problem:
> Many java windows that have child widgets are displayed incorrectly (like
> Oracle SQL developer, it's free, can be downloaded from Oracle site to test)
> when compiz is enabled. The child widgets are not displayed at all so the main
> window looks empty. If I disable compiz, widgets appear and remain visible even
> if compiz is enabled again but only until next app restart.

This is a java bug, which has been fixed for a while; in case you are using apps which ship a private JVM copy you can either download a version which uses the system JVM or try doing 
export AWT_TOOLKIT=MToolkit 
before starting the app.

Does this help?
Comment 2 The Source 2010-07-03 08:57:01 EDT
Exporting the variable leads to the following error:

Runtime link error - it appears that libXt got loaded before libXm,
which is not allowed.
java.lang.InternalError: libXt loaded before libXm
Comment 3 Adel Gadllah 2010-07-03 09:04:17 EDT
(In reply to comment #2)
> Exporting the variable leads to the following error:
> 
> Runtime link error - it appears that libXt got loaded before libXm,
> which is not allowed.
> java.lang.InternalError: libXt loaded before libXm    

So you are indeed using a broken JVM; is there a version available that does not ship with a private JVM?
Comment 4 Aram Agajanian 2010-07-16 10:23:53 EDT
One app that exhibits this problem is the the Management Console for Red Hat Directory Server 8.0.  Setting the AWT_TOOLKIT environment variable helps in this case.
Comment 5 Adel Gadllah 2010-07-16 10:43:24 EDT
(In reply to comment #4)
> One app that exhibits this problem is the the Management Console for Red Hat
> Directory Server 8.0.  Setting the AWT_TOOLKIT environment variable helps in
> this case.    

Yeah as I said above this is a bug which has been fixed in current java versions, "fixing" this in compiz would mean rewriting it to be a reparenting wm, which is a huge amount of work for no gain (as the issue is fixed in current java builds).

Note You need to log in before you can comment on or make changes to this bug.