Bug 60898 - Hampton beta2 install fails on S3Trio 3D systems
Summary: Hampton beta2 install fails on S3Trio 3D systems
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-08 16:50 UTC by Wendy Hung
Modified: 2007-04-18 16:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-21 19:15:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Wendy Hung 2002-03-08 16:50:19 UTC
Description of problem:
On IBM xSeries 250 and 240 systems with Trio3D video, anaconda dies when 
starting up.

How reproducible:
Always

Steps to Reproduce:
1. Boot from Hampton beta2 CD 1.

	
Actual Results:  Error message appears:

Running anaconda - please wait...
Probing for video card:   Traceback (innermost last):
  File "/usr/bin/anaconda", line 377, in ?
    videohw    = videocard.VideoCardInfo(skipDDCProbe = flags.test)
  File "/usr/lib/anaconda/videocard.py", line 410m in __init__
    server = "XF86_" + vc.getCardData()["SERVER"]
KeyError: SERVER
install exited abnormally
... (shutdown messages)



Expected Results:  Installation proceeds.

Additional info:

Occurs in both normal and low res mode. 

Text mode install doesn't even work.

Comment 1 Jeremy Katz 2002-03-08 19:49:01 UTC
This is because the hwdata package in beta2 had the trio3d listed as unsupported
in xfree4 and no xfree 3 driver listed.  That's already fixed in CVS.  We should
probably handle this case more gracefully though.

Comment 2 Wendy Hung 2002-03-21 19:15:50 UTC
Fixed in Beta3 (skipjack).


Note You need to log in before you can comment on or make changes to this bug.