Bug 608992 - Add "Boot system with basic video driver" option at the initial screen
Add "Boot system with basic video driver" option at the initial screen
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: David Huff
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On: 633827
Blocks: F14Beta/F14BetaBlocker
  Show dependency treegraph
 
Reported: 2010-06-29 02:56 EDT by He Rui
Modified: 2010-09-15 23:48 EDT (History)
9 users (show)

See Also:
Fixed In Version: livecd-tools-034-7.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-15 23:48:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Add basic video driver option to syslinux/isolinux configuration (2.33 KB, patch)
2010-08-14 18:02 EDT, Jasper O'neal Hartline
no flags Details | Diff

  None (edit)
Description He Rui 2010-06-29 02:56:15 EDT
Description of problem:

So far F-13 GA Live images have two boot options at the initial screen: "Boot", "Verify and Boot". But similar to the Fedora install images, LIVE images should also have a base video driver boot option to allow the system boot with xdriver=vesa.

Therefore, I propose to add "Boot system with basic video driver" option, which  specifies the parameters: xdriver=vesa nomodeset, since xdriver=vesa working is an important workaround for display problems.
Comment 1 Jasper O'neal Hartline 2010-08-12 00:27:49 EDT
This functionality needs to be implemented in live.py in the syslinux configuration section so that the Live media created whether they be nightly spins, or homemade livecd media do reflect a base level of conformity between media. This being the DVD/CD GA media and Live media.

The points made in the original report stating these options are workarounds for some graphics chipsets is very important to users who already know they may have a problem which is ongoing or for users who would have no other way to boot thier Live media without this option.


adamw has also requested this be added as a feature.
Comment 2 Adam Williamson 2010-08-12 00:54:48 EDT
note that passing xdriver= doesn't currently work. I'm working up a patch to spin-kickstarts for this. But yes, I think we should add this, for F14 Beta and future builds.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Jasper O'neal Hartline 2010-08-14 15:10:00 EDT
This commit made to spin-kickstarts will allow us to implement this functionality in livecd-tools as soon as possible. The original discussion was that this could be added as soon or before Beta release time.

http://git.fedorahosted.org/git/?p=spin-kickstarts.git;a=blobdiff;f=fedora-live-base.ks;h=ea24f2d58ec23abc40dc0ca9cc2e03fa18da197d;hp=3bde1cc953b3152a45a3176ad9ca061b77bfd663;hb=b500cb3bb951565ae27b461f7664fcaf86aa91b6;hpb=6e1f23814506c3105878d7d33125910efbebf25f
Comment 4 Jasper O'neal Hartline 2010-08-14 18:02:41 EDT
Created attachment 438805 [details]
Add basic video driver option to syslinux/isolinux configuration
Comment 5 Adam Williamson 2010-09-03 13:08:45 EDT
quick note on a wrinkle here - the 'nomodeset' parameter must not only be passed to the live environment but also set in the kernel configs for the *installed* system too (and of course the xorg config file must be installed), so that when you boot the live image with basic graphics mode and then install, the installed system also runs in 'basic graphics mode' (nomodeset and vesa as the X driver).

We discussed this at the blocker review meeting today and agreed to make it a beta blocker under the new Alpha criterion "The graphical boot menu for all installation images should include an entry which causes both installation and the installed system to use a generic, highly compatible video driver (such as 'vesa'). This mechanism should work correctly, launching the installer and attempting to use the generic driver". Technically this was added to the F15 criteria, not F14, but that was only because the F14 Alpha was already out, and we agreed that we can require it to be met for F14 Beta.
Comment 6 Bruno Wolff III 2010-09-03 13:20:08 EDT
What handles that part of the install? If it's anaconda, wouldn't it work the same as other installs? (I'm not sure which stuff is done by anaconda and which stuff is custom for livecd's.)
Comment 7 Bruno Wolff III 2010-09-03 13:22:04 EDT
As I tried to mention when I noticed that you guys were discussing something I could have helped with (but after endmeeting), the plan is to get a new livecd-tools release out this weekend with commited fixes and a couple of new scripts (that are used standalone).
Comment 8 Adam Williamson 2010-09-03 18:38:04 EDT
If you mean writing nomodeset to grub config for the installed system, I'm not entirely sure; there's a bug report indicating it may be broken for the traditional installer at present. We'd probably better test it and check what happens at present.
Comment 9 John Poelstra 2010-09-09 00:36:17 EDT
What are the plans for addressing and assessing this bug?  We'd love to have more information before the next blocker meeting this Friday.
Comment 10 Bruno Wolff III 2010-09-09 01:05:43 EDT
The plan is that I'm already supposed to have a new build of livecd-tools out, but am behind on getting it done. If Jasper's patch is good enough that may be enough. But I am not sure if there might be more to this based on other comments. I haven't personally looked into the problem. I'm just supposed to gather outstanding patches that are suitable and get them committed and a new version of the package built. Thursdays I am tied up all day, so it won't happen before Friday night.
Comment 11 Adam Williamson 2010-09-09 10:08:38 EDT
We'll need Jasper's patch as a minimum. I think it's probably also all we'll need to change in livecd-tools; the wrinkle I noted about having nomodeset written to the grub config post-install is still valid, but whether we need to do something to fix that or not, I don't think it would be in livecd-tools, but in anaconda. So I'd say go ahead and build a new livecd-tools with Jasper's patch and we'll work from there.
Comment 12 Bruno Wolff III 2010-09-11 15:01:41 EDT
I committed Jasper's patch for live.py upstream.
It looks like it is still a couple more hours of work collecting backlogged patches, but I expect to have a build ready for testing late tonight.
Comment 13 Fedora Update System 2010-09-12 00:20:36 EDT
livecd-tools-034-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/livecd-tools-034-1.fc14
Comment 14 Adam Williamson 2010-09-13 12:14:23 EDT
There's a small problem with the current implementation: it's configured as the *default* option, which is not what we want. We want the default to be 'Boot system', as it was before.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 15 Adam Williamson 2010-09-13 12:14:49 EDT
well, the problem's small in term of the fix being easy. it's not small in impact, it must be fixed for release.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 16 Bruno Wolff III 2010-09-13 12:23:12 EDT
I applied Jasper's patch in the 034 build. Does that fix the issue? If not what more is needed to fix it?
Is there a test case for this?
Comment 17 Adam Williamson 2010-09-13 12:34:05 EDT
i'm using 034, if I wasn't using that there wouldn't *be* any menu entry to test. what's needed to fix it is to make the newly-added menu entry not the default (I don't know how to do that).

I also just found a bigger problem in the 034 implementation: it doesn't add the 'nomodeset' parameter which is needed for this to work properly. just adding 'xdriver=vesa' isn't enough, the 'nomodeset' parameter must also be specified in this option (but not in any other, only this one).



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 18 Adam Williamson 2010-09-13 12:35:54 EDT
the test case for the first bug is simple - build a live image with the appropriate livecd-tools and boot it. hit tab at the 'ten second countdown' screen and check which menu entry is highlighted. for the second bug, well, an easy way to tell is that the graphical splash shouldn't be shown when using the 'basic video' boot option. you can also hit tab at the 'ten second countdown' screen and check if the 'nomodeset' parameter is in the default kernel parameters for the 'basic video' choice.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 19 Bruno Wolff III 2010-09-13 12:54:50 EDT
So let me read that back to you, so I have an idea of what I should work on tonight if no one beats me to it:

There are multiple boot menus, but the vesa one is not supposed to be the default. So that having the default be the other one will solve one remaining aspect of this issue.

The grub config for the vesa boot menu item needs " nomodeset" added to it.

Unfortunately I won't get to work on a new build until tonight (possibly late). I do think I can figure out how to do the above two things using the earlier patch as an example. I may not have time to do test live image composes before I need to sleep, so I may not know if what I change actually fixes the problem.
Comment 20 Adam Williamson 2010-09-13 13:18:49 EDT
I'd say "There are multiple boot menu entries", but yes, that's right. I had a quick look myself but the format of the boot menu entries for syslinux or whatever the hell we're using is very bizarre and I just couldn't figure out what to poke to change it.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 21 Fedora Update System 2010-09-13 14:10:26 EDT
livecd-tools-034-2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update livecd-tools'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/livecd-tools-034-2.fc14
Comment 22 Bruno Wolff III 2010-09-13 20:25:25 EDT
I started looking at this. It looks like the nomodeset can be set where the basic video driver is set to vesa for live boots. That doesn't cover installs defaulting to the same option.
It looks like the basic video stanzas were copied at a level that it is hard to deal with. I think defining just one at a time (with and without the basic video driver options passed) makes more sense. Then I think where the default is set, you can get it applied to the right one. I think right now it applies to the previous one and the basic one is defined second in a pair, so this might be what's making it the default.
I don't fully grok this, but I think I have a good idea to try.
Comment 23 Bruno Wolff III 2010-09-14 00:05:30 EDT
Please give this another try. I got one to boot with the right default menu. Unfortunately the labels were the same. I have a new build with that supposedly fixed, but I need to sleep and don't have time to build another test ISO.
Only booting is fixed by what I did. I don't know what the status of installs is.
Comment 24 Adam Williamson 2010-09-14 07:23:10 EDT
This one looks pretty good - the default is correct and the 'basic video' option has nomodeset included. I'm going to test installation now. One thing, though: my built live image had a grey background for the bootloader menu, not a Fedora image (as it should be). I did use the new https://admin.fedoraproject.org/updates/fedora-logos-14.0.0-1.fc14 fedora-logos package for this live image, instead of the current one in dist-f14. does livecd-tools have to be changed with this new fedora-logos, or is this some other bug?

when running livecd-iso-to-disk to write the image to a USB stick I got this error:

chattr: No such file or directory while trying to stat /media/usbdev.arLObL/syslinux/extlinux.sys

not sure if that's new, or if it's actually a problem.
Comment 25 Adam Williamson 2010-09-14 08:17:41 EDT
Okay, so aside from the grey bootloader issue, after installation from the 'basic video driver' option we currently leave a bad config: nomodeset is correctly added to kernel parameters, but there is no xorg.conf or xorg.conf.d/blahblah.conf to set vesa as the X driver. This is probably mostly my fault =) I adjusted livesys service to set it during live boot but the file created there obviously doesn't carry over to the installed system. I'll see if I can figure out what we need to do to have that file in the installed system.
Comment 26 Bruno Wolff III 2010-09-14 08:24:18 EDT
For the background image it would be nice to know if that was introduced by livecd-iso-to-disk or if it happens in the original ISO as well. Also I seem to remember there were some issues with the artwork showing F13 and version neutral background was supposed to be developed for beta. Maybe this is related to that?

The chattr error is probably a new bug, but might not be that important. I won't get a chance to look at that until tonight at the earliest.

For the install, you'll probably want to have liveinst do something different based on the vesa driver being used when it is run.
Comment 27 Adam Williamson 2010-09-14 09:27:28 EDT
The ISO has grey background as well (I wrote it to a DVD to test installation). Yes, the artwork stuff you mention is what changed in that new fedora-logos build I referred to: you might want to take a look at what changed in that and see if livecd-tools needs to reflect it somehow.

I've talked to anaconda devs briefly about the install issue. akozumpl suggested running liveinst with --xdriver vesa parameter and see if that works. I'm testing that now. If it works, we can try to set up the livecd stuff so that, somehow, it runs liveinst with that parameter if you specify xdriver on the kernel command line. The other option is to use some other mechanism to have the live install process write an xorg.conf (or xorg.conf.d) file when xdriver= is specified in the command line. I'm not really familiar with what (if any) mechanisms we have to allow the live install process to modify the installed system differently from how anaconda usually does it, so I'm really not sure which of these options is best. Do you have thoughts on that? Do you know who else would know?
Comment 28 Bruno Wolff III 2010-09-14 10:20:16 EDT
I'll check out the artwork. Stuff really shouldn't move around as that makes it hard to have livecd-tools work across releases.

If liveinst --xdriver vesa works, then I think we could at least do a customization to the desktop icon for running liveinst for liveuser at boot. That would probably be a good enough solution.
Comment 29 Adam Williamson 2010-09-14 10:29:51 EDT
Brian's going to look at the anaconda side in the bug he's just marked as blocking this one, he has some ideas.
Comment 30 James Laska 2010-09-14 15:59:44 EDT
While testing the updated fedora-logos package using a custom build Live image, it seems the syslinux/syslinux.cfg created by livecd-tools doesn't properly reference the splash.png (see comparison between F-13 and F-14 syslinux.cfg at http://fpaste.org/gymS/).

Could the latest updates have introduced this change?
Comment 31 Bruno Wolff III 2010-09-14 16:14:03 EDT
That's what it looks like. Tom has committed a patch to the package. He hasn't done a build yet, but I'll do one tonight if he hasn't. I also commit the same change upstream.
Thanks.
Comment 32 James Laska 2010-09-14 20:02:37 EDT
Looks like a build is available.  I'll be able to test tomorrow.

https://admin.fedoraproject.org/updates/livecd-tools-034-7.fc14
Comment 33 Fedora Update System 2010-09-14 23:23:14 EDT
livecd-tools-034-7.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/livecd-tools-034-7.fc14
Comment 34 Fedora Update System 2010-09-15 02:52:34 EDT
livecd-tools-034-7.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update livecd-tools'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/livecd-tools-034-7.fc14
Comment 35 James Laska 2010-09-15 09:28:46 EDT
Confirmed that a new (non-default) boot option is present with live images created using livecd-tools-034-7.fc14.  The boot option is titled "Boot (Basic Video)" and contains the kernel options "xdriver=vesa nomodeset".
Comment 36 Adam Williamson 2010-09-15 12:26:27 EDT
with current livecd-tools this looks good, we can close when it goes stable i think. please submit it.
Comment 37 Bruno Wolff III 2010-09-15 12:41:21 EDT
I requested a push to stable.
Comment 38 Fedora Update System 2010-09-15 23:47:20 EDT
livecd-tools-034-7.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.