Bug 60901 - TTF causes xftcache segfault
Summary: TTF causes xftcache segfault
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-08 19:16 UTC by Sammy
Modified: 2007-04-18 16:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-11 17:12:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sammy 2002-03-08 19:16:59 UTC
This is not the default but if you add the TTF directory to the directories
in XftConfig file that xftcache starts to segfault every time and if one is
using anti-aliasing the desktop never comes on after login.

Comment 1 Mike A. Harris 2002-03-11 06:29:51 UTC
Please attach the problem config file

Comment 2 Mike A. Harris 2002-03-11 06:31:31 UTC
What font files are in the TTF directory?

Comment 3 Mike A. Harris 2002-03-11 06:34:46 UTC
Also, what version of the following (and please upgrade to the latest if you
haven't already)

freetype
XFree86


Comment 4 Sammy 2002-03-11 17:12:05 UTC
I only have the fonts that came with the rpm in the TTF directory.

The same problem with 4.2.0-6.32 AND 4.2.0-6.41

Freetype version is 2.0.6-3.

I have another directory that comes from ttfonts rpm BUT also contains the
Microsoft's version of tt fonts. This is also listed in XftConfig.

This happens with both the standard config file that is in the rpm except TTF
directory added or a slightly modified config file that I have. In both cases
just commenting the TTF directory line allows xftcache to work.



Comment 5 Sammy 2002-03-18 16:58:14 UTC
The problem is resolved in XFree86-4.2.0-6.47 and freetype-2.0.9-1.
Closing....



Note You need to log in before you can comment on or make changes to this bug.