Bug 60903 - RFE: remove unexpected IOAPIC warnings on Discovery
RFE: remove unexpected IOAPIC warnings on Discovery
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Larry Woodman
Brian Brock
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-08 15:09 EST by Matt Domsch
Modified: 2007-11-30 17:06 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-18 09:56:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Domsch 2002-03-08 15:09:57 EST
Description of Problem:
Discovery implements an IOAPIC, reg01.version=0x20, reg01.PRQ (bit 15) = 1, per 
the Intel 82806 AA IOAPIC spec.  
ftp://download.intel.com/design/chipsets/datashts/29802502.pdf

Hampton kernels include detection of this which prevent the warnings about an 
unknown IOAPIC from appearing at bootup for each IOAPIC (we've got 7 on 
Discovery, thus 14 warnings on each boot).  Since the version bits and PRQ bit 
isn't used anywhere else in the kernel that I can see, I'd like to see these 
warnings removed in Pensacola by adding recognition of these.

While Pensacola isn't directly targeting Discovery, we do intend to certify 
Discovery on Pensacola, thus it would be nice to remove these warnings.

Version-Release number of selected component (if applicable):
2.4.7-10 through 2.4.9-31 show the warning (at least)
2.4.18-0.1 doesn't.


How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Arjan van de Ven 2002-03-13 06:15:09 EST
               (reg_01.version != 0x13) && /* Xeon IO-APICs */
-              (reg_01.entries != 0x20)    /* Intel P64H (82806 AA) */
+              (reg_01.version != 0x20)    /* Intel P64H (82806 AA) */

making the kernel actually check the version instead of some other field helps a
great deal in recognizing the chip......
Comment 2 Matt Domsch 2002-03-13 10:36:15 EST
And this too please if you would.  This makes the second warning disappear 
because the PRQ bit is actually set.

--- linux/include/asm-i386/io_apic.h~  Wed Feb 20 07:16:01 2002
+++ linux/include/asm-i386/io_apic.h   Wed Mar 13 09:54:52 2002
@@ -29,7 +29,8 @@ struct IO_APIC_reg_00 {

 struct IO_APIC_reg_01 {
        __u32   version         :  8,
-               __reserved_2    :  8,
+               __reserved_2    :  7,
+               PRQ             :  1,
                entries         :  8,
                __reserved_1    :  8;
 } __attribute__ ((packed));

Comment 3 Matt Domsch 2002-07-24 10:29:01 EDT
Fixed in 2.4.9-e.5 and e.8.  Closing.

Note You need to log in before you can comment on or make changes to this bug.