Bug 609071 - python crashes with various exceptions
Summary: python crashes with various exceptions
Status: CLOSED DUPLICATE of bug 607650
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-29 11:24 UTC by Ales Kozumplik
Modified: 2014-09-30 23:39 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-29 15:25:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
exception 1 (4.69 KB, image/png)
2010-06-29 11:24 UTC, Ales Kozumplik
no flags Details
exception 2 (5.47 KB, image/png)
2010-06-29 11:26 UTC, Ales Kozumplik
no flags Details
Exception report in Anaconda with RHEL 6 beta 2 (x86_64) in a VM (80.86 KB, text/plain)
2010-07-01 20:25 UTC, Justin Clift
no flags Details
Screenshot of the text mode Anaconda error (27.88 KB, image/png)
2010-07-01 20:28 UTC, Justin Clift
no flags Details

Description Ales Kozumplik 2010-06-29 11:24:04 UTC
Description of problem:

In 0628.n.3 an x86_64 install on qemu-kvm crashes occasionally with various errors in python, possibly because of memory corruption.

This might or might not be related to 607650 where an abort() is called in glibc C code because of a corrupted data structure.

Comment 1 Ales Kozumplik 2010-06-29 11:24:37 UTC
Created attachment 427650 [details]
exception 1

Comment 2 Ales Kozumplik 2010-06-29 11:26:45 UTC
Created attachment 427651 [details]
exception 2

Comment 3 Ales Kozumplik 2010-06-29 11:27:54 UTC
Note: I don't know of anyone (the Brno RTT or myself) who has seen this on anything else except x86_64 qemu-kvm virtual machine.

Comment 5 RHEL Product and Program Management 2010-06-29 11:43:06 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 6 Andrea Arcangeli 2010-06-29 14:44:30 UTC
Is there any swap in use, especially on the host? Do you run KSM?

Thanks!

Comment 7 Ales Kozumplik 2010-06-29 15:03:05 UTC
Andrea, let's keep the communication at the bug 607650.

Comment 8 Andrea Arcangeli 2010-06-29 15:10:44 UTC
ok so we can close this as a duplicate of 607650?

Comment 9 Ales Kozumplik 2010-06-29 15:25:00 UTC
You're right, let me close this.

*** This bug has been marked as a duplicate of bug 607650 ***

Comment 10 Justin Clift 2010-07-01 20:24:00 UTC
This appears to be the bug I'm hitting (most times!) when installing RHEL 6 beta 2 (x86_64) in a VM on Fedora 13.

It's randomly flaking out when detecting storage, when installing packages, etc. :(

I'd prefer to communicate through BZ 607650, but that bug is non-public, giving Access Denied errors. :(

Managed to save an exception report with a recent crash, so I'll attach that in case it's useful.

Comment 11 Justin Clift 2010-07-01 20:25:43 UTC
Created attachment 428554 [details]
Exception report in Anaconda with RHEL 6 beta 2 (x86_64) in a VM

Comment 12 Justin Clift 2010-07-01 20:28:53 UTC
Created attachment 428555 [details]
Screenshot of the text mode Anaconda error


Note You need to log in before you can comment on or make changes to this bug.