Bug 60918 - SSL_connect error in up2date, rhn_register, rhn_check
SSL_connect error in up2date, rhn_register, rhn_check
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-08 18:24 EST by Need Real Name
Modified: 2015-01-07 18:55 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-08 22:53:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-03-08 18:24:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98; Win 9x 4.90; Q312461)

Description of problem:
A previously working system can no longer use rhn updating. A "SSL_connect 
error" is always reported. An Ethereal trace shows a "Bad Certificate" packet 
as the last sent in each attempt.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Simply run any of the above programs.
2.
3.
	

Actual Results:  bombs out with "SSL_connect error" message

Expected Results:  normal operation

Additional info:

1. Tried uninstalling and re-installing up2date & rnh_register.
2. Confirmed that I could log into my rhn account from this machine.
3. Another system on the same LAN has no such problems.
4. After a number of exchanges with the RHN Team, they suggested reporting this 
bug.
Comment 1 Need Real Name 2002-03-08 22:53:16 EST
I found the problem! My RTC had reset. After restoring date & time, all 
recovered. Please withdraw this bug report.

Note You need to log in before you can comment on or make changes to this bug.