Bug 609265 - cannot setup kerberos auth with gui
cannot setup kerberos auth with gui
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: authconfig (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-29 15:38 EDT by Zing
Modified: 2010-06-30 03:16 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-30 03:16:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zing 2010-06-29 15:38:00 EDT
Description of problem:

I couldn't turn on kerberos authentication with authconfig-gtk... it's completely grayed out.  I had to use authconfig-tui, which did work.


Version-Release number of selected component (if applicable):
authconfig-6.1.4-2.fc13.x86_64

How reproducible:
all the time


Steps to Reproduce:
1. run authconfig-gtk
2. try to setup kerberos authentication
  
Actual results:
3. the input fields are all greyed out.


Expected results:
3. setup kerberos authentication.
Comment 1 Tomas Mraz 2010-06-29 16:03:00 EDT
Do you have pam_krb5 package installed?

Authconfig GUI requires it for kerberos auth because some configurations are not supported with SSSD.
Comment 2 Zing 2010-06-29 19:32:22 EDT
Yes, pam_krb5 is installed.

This was a new "Graphical Desktop" F13 install.  I first noticed the problem in "first boot" where authconfig-gtk is exec'd, I couldn't configure kerberos auth.

I see if I choose another "User Account Database" other than "Local accounts only" then Kerberos lights up as a choice (I don't see SSSD listed anywhere so I'm not sure how that fits in).  For some reason, the kerberos auth method is unavailable with "Local accounts only", which is what I was trying to do.
Comment 3 Tomas Mraz 2010-06-30 03:16:35 EDT
Ah so. This is on purpose - the GUI allows setting up only the most usual use-cases. Local user identity with krb5 auth is not amongst them.

Note You need to log in before you can comment on or make changes to this bug.