Bug 60928 - Frequent X lockups since upgrading to 4.1.0-15
Frequent X lockups since upgrading to 4.1.0-15
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-09 07:13 EST by Need Real Name
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-02 18:29:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Here's a copy of the X logfile after a lockup (24.55 KB, text/plain)
2002-03-09 07:15 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-03-09 07:13:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020212

Description of problem:
A few weeks back, I upgraded to RH's XFree86 4.1.0-15.  Ever since then, I've
experienced random lockups. X doesn't crash, but locks up completely:  no more
activity on the screen, mouse pointer doesn't move anymore, not responsive to
keyboard (not even ctrl-all-backspace). The only way out is a hard reset of the
system.

I don't have any other machines connected to this machine, so I can't log in
remotely to find out if the kernel is still running fine, but I think it's most
likely that it is X that locks up, not the kernel: I defintely don't see any
kernel messages in /var/log/messages to indicate that.

Up till two weeks ago, I was using NVidia's proprietary drivers. Since getting
the lockups, I've switched to XFree86's own nvidia driver, but the problem remains.

Note: I've never had _any_ problems with X locking up prior to upgrading to
XFree86 4.1.0-15.  The system had been running fine ever since installing RH7.2
when it came out.

I'll post a copy of the XFree86.0.log, but it doesn't really show any problems.


Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
The problem is very intermittent: sometimes it doesn't happen for days, then it
happens three times in one day.


Additional info:
Comment 1 Need Real Name 2002-03-09 07:15:05 EST
Created attachment 48002 [details]
Here's a copy of the X logfile after a lockup
Comment 2 Mike A. Harris 2002-03-11 01:25:55 EST
Run X in runlevel 3 if not doing so already, then do the following:

startx &> x.log

After it crashes, attach x.log, XFree86.0.log, XF86Config-4,
/var/log/messages to the report, as well as the output of:

lsmod
uname -a
Comment 3 Need Real Name 2002-05-02 18:29:33 EDT
Just to keep you posted: after discussing this with several people, I disabled
the gnome event sounds. Since then, I haven't had a single re-occurance of this
crash.

Apparently, there may be a conflict between the video card (GeForce) and the
audio card (SB Live).
Comment 4 Mike A. Harris 2002-05-21 01:58:11 EDT
Closing bug NOTABUG, sounds like a hardware issue.

Note You need to log in before you can comment on or make changes to this bug.