Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 609321 - case-insensitive searches against "mail" attribute not working
case-insensitive searches against "mail" attribute not working
Status: CLOSED DUPLICATE of bug 559315
Product: 389
Classification: Retired
Component: Schema (Show other bugs)
1.2.5
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Rich Megginson
Chandrasekar Kannan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-29 19:57 EDT by devonab
Modified: 2015-01-04 18:43 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-29 20:05:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description devonab 2010-06-29 19:57:48 EDT
Description of problem: case-insensitive queries of thr mail attribute do not work. case sensitive searches do. this seems to be an issue with the IA5String data type.  I tried updating the schema to use the DirectoryString data type but that didn't work. 


Version-Release number of selected component (if applicable): 1.2.5


How reproducible: always


Steps to Reproduce:
1. add entry using John.Doe@domain.com to directory
2. ldapsearch -x -LLL -h host -b basedn mail=john.doe@domain.com
3.
  
Actual results:
empty result set

Expected results:
expect to see the john doe entry

Additional info:
Comment 1 Rich Megginson 2010-06-29 20:05:29 EDT

*** This bug has been marked as a duplicate of bug 559315 ***

Note You need to log in before you can comment on or make changes to this bug.