Bug 60934 - System locks up nightly with a kernel drm error
System locks up nightly with a kernel drm error
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.2
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-09 12:02 EST by John
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-10 23:29:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The XF86Config-4 (1.79 KB, text/plain)
2002-03-09 12:04 EST, John
no flags Details
The output of 'lspci -v' (3.33 KB, text/plain)
2002-03-09 12:06 EST, John
no flags Details
/proc/interrupts (642 bytes, text/plain)
2002-03-09 12:06 EST, John
no flags Details
/var/log/XFree86.0.log (75.89 KB, text/plain)
2002-03-10 23:27 EST, John
no flags Details
/var/log/XFree86.9.log (25.97 KB, text/plain)
2002-03-10 23:28 EST, John
no flags Details
/var/log/message.1 (504.64 KB, text/plain)
2002-03-10 23:29 EST, John
no flags Details

  None (edit)
Description John 2002-03-09 12:02:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.1.3 (X11; Linux i686; U;) Gecko/20020205

Description of problem:
We've set up a new dual Athlon MP workstation, running RedHat 7.2.
Everything is running smoothly, except it has crashed each of its
first three nights!

When we reboot it in the morning, we find the following sort of message in the log:
Mar  8 20:07:47 etc kernel: [drm:radeon_freelist_get] *ERROR* returning NULL!,
and then messages saying that this message has been repeated many times.
(The full output is shown below.)

As you can tell from the log entry, the video card is a Radeon.  All
of the XF86Config-4 settings are those autodetected by Xconfigurator.

The machine is stock RH7.2, and completely up2date.

(Since it happens nightly, we suspect that some screensaver is
triggering the X/DRM bug.  We haven't figure out which one, though.
It doesn't seem correlated with any cron job.)

I'm going to attach 'lspci -v,' 'cat /proc/interrupts,' and the
XF86Config-4.

Thanks for looking into this,
John

Version-Release number of selected component (if applicable):
XFree86-4.1.0-15
kernel-smp-2.4.9-31  (It's the athlon kernel.)

How reproducible:
Always

Steps to Reproduce:
0. find a machine like ours :)
1. Install RH7.2
2. up2date everything
3. wait
	

Actual Results:
Mar  8 20:07:47 etc kernel: [drm:radeon_freelist_get] *ERROR* returning NULL!
Mar  8 20:08:18 etc last message repeated 1353 times
Mar  8 20:09:19 etc last message repeated 2774 times
Mar  8 20:10:20 etc last message repeated 2735 times
Mar  8 20:11:21 etc last message repeated 2791 times
Mar  8 20:12:22 etc last message repeated 2720 times
Mar  8 20:13:23 etc last message repeated 2819 times
Mar  8 20:14:26 etc last message repeated 2675 times
Mar  8 20:15:27 etc last message repeated 2772 times
Mar  8 20:16:28 etc last message repeated 2708 times
Mar  8 20:17:29 etc last message repeated 2749 times
Mar  8 20:17:47 etc last message repeated 842 times


Expected Results:  The machine should stay up without crashing for years. :)

Additional info:
Comment 1 John 2002-03-09 12:04:37 EST
Created attachment 48022 [details]
The XF86Config-4
Comment 2 John 2002-03-09 12:06:05 EST
Created attachment 48023 [details]
The output of 'lspci -v'
Comment 3 John 2002-03-09 12:06:49 EST
Created attachment 48024 [details]
/proc/interrupts
Comment 4 Mike A. Harris 2002-03-10 21:57:33 EST
Please attach X log, and /var/log/messages
Comment 5 John 2002-03-10 23:26:23 EST
Ok, here's the info you requested.

We set the screensaver only blank the screen on Friday, and it hasn't
crashed since.  Hopefully that will be useful information to someone. :)

I'm including both X logs that were in /var/log, and /var/log/message.1,
which logs most of the history of the install. (/var/log/messages only
contains today's ssh and su activity, and it hasn't crashed over that
time period,. so I haven't included it.

Let me know if there is any other info you need.
Comment 6 John 2002-03-10 23:27:26 EST
Created attachment 48086 [details]
/var/log/XFree86.0.log
Comment 7 John 2002-03-10 23:28:12 EST
Created attachment 48087 [details]
/var/log/XFree86.9.log
Comment 8 John 2002-03-10 23:29:10 EST
Created attachment 48088 [details]
/var/log/message.1
Comment 9 Mike A. Harris 2002-07-26 07:14:19 EDT
I've just tried to reproduce this problem again using Red Hat Linux 7.3
and both a Radeon VE, and a Radeon 7000 card (the newer VE).  The problem
does not occur for me with either card.  I'm closing this as fixed
in Red Hat Linux 7.3 (CURRENTRELEASE).

If you still have the problem with 7.3, please reopen.
Comment 10 John 2002-07-26 11:45:21 EDT
Were you able to reproduce the problem with 7.2?

We'll upgrade that machine in the next week or two, to see if that fixes the
problem.

Thanks for checking into this!

Note You need to log in before you can comment on or make changes to this bug.