This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 609345 - files/ directory not included in the src.rpm created by "publican package"
files/ directory not included in the src.rpm created by "publican package"
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-29 23:33 EDT by Misty Stanley-Jones
Modified: 2014-06-18 03:03 EDT (History)
5 users (show)

See Also:
Fixed In Version: 2.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-05 00:17:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Misty Stanley-Jones 2010-06-29 23:33:25 EDT
Description of problem:
If I <ulink> to a file in the $BOOK/en-US/files directory, and run 'publican package' on the book, the files/ directory is not included in the resulting .src.rpm. 

Version-Release number of selected component (if applicable):
publican-1.6.3-0.fc13.noarch


How reproducible:
Always

Steps to Reproduce:
1. <ulink> to a file within the files/ directory, such as: <ulink url="files/examples.zip" />
2. Run "publican package --lang=en-US"
3. Install and build the .src.rpm on a different system and attempt to click the link in the built book
  
Actual results:
Get a 404 error because the files/ directory and its contents are omitted


Expected results:
The linked file opens or downloads


Additional info:
Workaround: Put the file into images/ instead and ulink to that.
Comment 1 Jeff Fearn 2010-06-30 01:37:59 EDT
Made sure files dir is added to tar used for srpm creation.

Fixed in build: 1.6.3-0.t118

Note You need to log in before you can comment on or make changes to this bug.