Bug 609345 - files/ directory not included in the src.rpm created by "publican package"
Summary: files/ directory not included in the src.rpm created by "publican package"
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Publican
Classification: Community
Component: publican
Version: 1.6
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jeff Fearn 🐞
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-30 03:33 UTC by Misty Stanley-Jones
Modified: 2014-06-18 07:03 UTC (History)
5 users (show)

Fixed In Version: 2.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-08-05 04:17:13 UTC


Attachments (Terms of Use)

Description Misty Stanley-Jones 2010-06-30 03:33:25 UTC
Description of problem:
If I <ulink> to a file in the $BOOK/en-US/files directory, and run 'publican package' on the book, the files/ directory is not included in the resulting .src.rpm. 

Version-Release number of selected component (if applicable):
publican-1.6.3-0.fc13.noarch


How reproducible:
Always

Steps to Reproduce:
1. <ulink> to a file within the files/ directory, such as: <ulink url="files/examples.zip" />
2. Run "publican package --lang=en-US"
3. Install and build the .src.rpm on a different system and attempt to click the link in the built book
  
Actual results:
Get a 404 error because the files/ directory and its contents are omitted


Expected results:
The linked file opens or downloads


Additional info:
Workaround: Put the file into images/ instead and ulink to that.

Comment 1 Jeff Fearn 🐞 2010-06-30 05:37:59 UTC
Made sure files dir is added to tar used for srpm creation.

Fixed in build: 1.6.3-0.t118


Note You need to log in before you can comment on or make changes to this bug.