Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 609354 - imsettings-stop cannot stop IBus running
imsettings-stop cannot stop IBus running
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: imsettings (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Akira TAGOH
QE Internationalization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-30 00:18 EDT by Kenichi Takemura
Modified: 2014-08-04 18:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-30 01:09:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kenichi Takemura 2010-06-30 00:18:44 EDT
Description of problem:

imsettings-stop cannot stop IBus running in a case provided in steps.

Version-Release number of selected component (if applicable):
imsettings-0.108.0-3.2.el6.x86_64
RHEL Version:Red Hat Enterprise Linux Workstation release 6.0 Beta (Santiago)
Kernel:2.6.32-37.el6.x86_64


How reproducible:
everytime I have test.

Steps to Reproduce:
1. Enable IBus from im-chooser
2. type # imsettings-stop from a terminal
   (Stopped IBus)
3. type # imsettings-start from a terminal
   (Started none)
4. Enable IBus from im-chooser
5. type # imsettings-start from a terminal
   (Unable to keep Input method running)
6. type # imsettings-stop from a terminal
   (No Input Method running...)

Actual results:

Step3: Cannot start IBus by imsettings-start
Step6: Cannot stop IBus by imsettings-stop

Expected results:

Step3: Can start IBus by imsettings-start
Step6: Can stop IBus by imsettings-stop

Additional info:
Comment 2 RHEL Product and Program Management 2010-06-30 00:43:07 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Akira TAGOH 2010-06-30 01:09:17 EDT
(In reply to comment #0)
> 3. type # imsettings-start from a terminal
>    (Started none)

This is correct behaviour. you have to do imsettings-stop -n to avoid updating your .xinputrc.

> 4. Enable IBus from im-chooser
> 5. type # imsettings-start from a terminal
>    (Unable to keep Input method running)

This is also correct behaviour. you have to do imsettings-start --cond-start to avoid trying to invoke IM twice.

> 6. type # imsettings-stop from a terminal
>    (No Input Method running...)

Since imsettings is capable to keep the status of multiple IMs on track but one for one IM, this is also correct behaviour since imsettings thinks ibus session is closed by the error at step 5.

Note You need to log in before you can comment on or make changes to this bug.