Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 609362 - oom killed unrelated processes for Desktop workload
oom killed unrelated processes for Desktop workload
Status: CLOSED DUPLICATE of bug 645770
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-30 01:38 EDT by Qian Cai
Modified: 2010-10-24 20:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-24 20:59:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg when oom happened (30.33 KB, text/plain)
2010-06-30 01:44 EDT, Qian Cai
no flags Details

  None (edit)
Description Qian Cai 2010-06-30 01:38:27 EDT
Description of problem:
When using a program to malloc memory bigger than system memory + swap, it killed non-related processes like devkit-power-daemon, gconfd-2, gvfsd, NetworkManager, gvfsd-trash etc on my T400 laptop installed standard Desktop distro.

Version-Release number of selected component (if applicable):
kernel-2.6.32-37.el6.x86_64
RHEL6-20100622.1 tree

How reproducible:
always
Comment 1 Qian Cai 2010-06-30 01:44:51 EDT
Created attachment 427862 [details]
dmesg when oom happened
Comment 2 Qian Cai 2010-06-30 23:39:02 EDT
This is more a long term item to make the OOM smarter - http://lwn.net/Articles/359998/
Comment 4 Qian Cai 2010-10-24 20:59:42 EDT

*** This bug has been marked as a duplicate of bug 645770 ***

Note You need to log in before you can comment on or make changes to this bug.