Bug 60939 - RFE: allow multiple network device setup in kickstart
RFE: allow multiple network device setup in kickstart
Status: CLOSED DUPLICATE of bug 64108
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
: FutureFeature
Depends On:
  Show dependency treegraph
Reported: 2002-03-09 16:37 EST by Peter Bowen
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-05-01 12:47:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Peter Bowen 2002-03-09 16:37:10 EST
if you have multiple network lines in your ks.cfg, the gateway and nameserver
options from the last one are the ones used, even if they are null.

The fix is to have the setNetwork function in installclass.py check for non-null
gateway and nameserver arguments before setting the gateway and primaryNS
properties of the id.network object

This is known to be broken in 7.2 and does not appear to be fixed in beta2.
Comment 1 Jeremy Katz 2002-03-13 16:42:50 EST
Known to be broken?  Where is the bug reported against 7.2?

Additionally only one network line is supported in kickstart... having more than
one gets you into territory of things that if they work, great... but if not,
then it's not entirely unexpected
Comment 2 Peter Bowen 2002-03-13 16:53:50 EST
I tested this in both 7.2 and the beta, but it seemed pointless to file against
7.2 at this point.  Hence the known to be broken statement.

However, if only one network line is supported, then this is a RFE for allowing
multiple network lines for different devices.
Comment 3 Jeremy Katz 2002-03-14 12:36:27 EST
Marking as an enhancement and deferring.  We're in feature freeze at this point.
Comment 4 Jeremy Katz 2002-05-03 01:32:22 EDT

*** This bug has been marked as a duplicate of 64108 ***

Note You need to log in before you can comment on or make changes to this bug.