Bug 609400 - Usability RFE: Reboot, Shutdown, Force Off icons on context menu shouldn't be in submenu
Usability RFE: Reboot, Shutdown, Force Off icons on context menu shouldn't be...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
: FutureFeature
Depends On:
Blocks: 693512
  Show dependency treegraph
 
Reported: 2010-06-30 04:24 EDT by Justin Clift
Modified: 2011-07-19 14:41 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-19 14:41:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Clift 2010-06-30 04:24:10 EDT
Description of problem:

In the Virtual Machine Manager GUI console window, the task bar has icons for Starting, Pausing, and Shutting Down the virtual machine.  There are additional options (Reboot, Shut Down, Force Off) available in a drop down menu in another task bar icon.

Promoting these options from the drop down menu, to the main task bar itself, would be a nice usability improvement.

When using a lot of virtual machines which are recreated often (ie in a lab/testing environment), having that extra mouse click becomes a real usability drag. :/

This is also the case for these power options in the right click context menu in the main virt-manager window.  Moving them directly into the right click context menu itself would be a win, reducing the number of mouse clicks for these often used actions.


Version-Release number of selected component (if applicable):

virt-manager-0.8.2-3.el6.noarch.rpm


How reproducible:

Every time.
Comment 2 RHEL Product and Program Management 2010-06-30 04:47:41 EDT
This feature request did not get resolved in time for Feature Freeze
for the current Red Hat Enterprise Linux release and has now been
denied. It has been proposed for the next Red Hat Enterprise Linux
release. If you would still like it considered for the current
release as an exception, please make that request with your support
representative.
Comment 3 Cole Robinson 2011-04-07 12:49:52 EDT
Expanding the shutdown options in the context menu is doable I think, I'd have to implement it and see how it looks. But I don't think doing so on the toolbar is a good idea.

Firstly I don't really think the extra click is that prohibitive. Also consider shutdown/reboot/destroy might be used by developers quite a bit but for people doing server virt this is probably not a common operation. Additionally we don't want to make 'force poweroff' a first class citizen since it's a potentially dangerous operation. We've also had UI designers sign off on the menu bar configuration. 

That said I doubt that the pause operation is used very much, but it gets a front row seat :) I think that's more an argument for demoting 'pause' than for promoting the shutdown options though.

Deferring to 6.2 for possibly changing the context menu.
Comment 6 Cole Robinson 2011-07-19 14:41:50 EDT
After playing with expanding the shutdown options in the menu bar and context menus, I don't think this is a good idea. Greatly balloons the size of the menus for IMO little usability gain. So I don't think there is anything that needs improvement here.

Closing as NOTABUG

Note You need to log in before you can comment on or make changes to this bug.