Bug 609422 - VM can't be started after being attached disk with virsh
Summary: VM can't be started after being attached disk with virsh
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libvirt   
(Show other bugs)
Version: 5.5
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Jiri Denemark
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords:
: 638071 (view as bug list)
Depends On:
Blocks: 632580
TreeView+ depends on / blocked
 
Reported: 2010-06-30 09:17 UTC by Mark Wu
Modified: 2018-11-14 19:00 UTC (History)
9 users (show)

Fixed In Version: libvirt-0.8.2-4.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 632580 (view as bug list)
Environment:
Last Closed: 2011-01-13 23:13:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:0060 normal SHIPPED_LIVE libvirt bug fix and enhancement update 2011-01-12 17:22:30 UTC

Comment 2 Mark Wu 2010-06-30 09:41:18 UTC
I can't find how does the diver name 'qemu' impact the process of building command line for qemu. So is it possible to remove the checking for driver name?
Otherwise, we should make 'qemu' become a valid driver name for virsh.

Comment 4 Jiri Denemark 2010-09-09 11:53:19 UTC
This is fixed upstream by 12a41822e14b558f7ffb4812978b957f3d228f23

Comment 7 Jiri Denemark 2010-09-10 13:45:16 UTC
A follow-up upstream patch dfec22cc6035a95ff1c7609ea060029cb99182cc is needed to deal with the issue more completely

Comment 8 Jiri Denemark 2010-09-13 21:54:41 UTC
Fix built into libvirt-0.8.2-4.el5

Comment 10 Jiri Denemark 2010-09-29 14:00:15 UTC
*** Bug 638071 has been marked as a duplicate of this bug. ***

Comment 11 Johnny Liu 2010-10-20 04:52:55 UTC
Verify this bug with libvirt-0.8.2-7.el5 on RHEL5u6 Server x86_64 kvm, and PASSED.

Now libvirt allow user to specify driver name.

1. Start a guest.
2. Add a disk using virsh command:
# virsh attach-disk rhel5u5 /dev/VolGroup00/lvolhome vda --sourcetype block --driver qemu --subdriver raw 
Disk attached successfully
3. Check the new disk xml
<snip>
    <disk type='block' device='disk'>
      <driver name='qemu' type='raw'/>
      <source dev='/dev/VolGroup00/lvolhome'/>
      <target dev='vda' bus='virtio'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x04' function='0x0'/>
    </disk>
<snip>

The new disk works fine in guest.
4. Shut down the guest, and start it successfully.
# virsh start rhel5u5
Domain rhel5u5 started

Comment 12 min zhan 2010-10-26 09:06:25 UTC
Verified with passed on below environments according to comment 11:
-RHEL5.6-Server-x86_64-KVM 
-RHEL5.6-Server-x86_64-Xen
-RHEL5.6-Client-i386-Xen
-RHEL5.6-Server-ia64-Xen

kernel-xen-2.6.18-228.el5
xen-3.0.3-117.el5
kvm-qemu-img-83-205.el5
kernel-2.6.18-228.el5
libvirt-0.8.2-8.el5

Comment 14 errata-xmlrpc 2011-01-13 23:13:36 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-0060.html


Note You need to log in before you can comment on or make changes to this bug.