Bug 60947 - On perl upgrade mod_perl doesn't work anymore
On perl upgrade mod_perl doesn't work anymore
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: perl (Show other bugs)
7.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Chip Turner
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-10 01:27 EST by James Antill
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-10 15:16:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Antill 2002-03-10 01:27:11 EST
Description of Problem:
When rhn upgraded one of my machines to perl-5.6.1-26.72.3 the apache on the
machine wouldn't boot anymore apache-1.3.22-2. Commenting out the mod_perl stuff
in the apache config. allowed apache to boot.
RHN system id is ID-1000565896

Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 James Antill 2002-03-10 15:16:44 EST
Forgot to add, here is the error message...

# /etc/init.d/httpd start
Starting httpd: [Sun Mar 10 01:05:02 2002] [error] Can't locate strict.pm in
@INC (@INC contains: /usr/lib/perl5/5.6.0/i386-linux /usr/lib/perl5/5.6.0
/usr/lib/perl5/site_perl/5.6.0/i386-linux /usr/lib/perl5/site_perl/5.6.0
/usr/lib/perl5/site_perl . /etc/httpd/ /etc/httpd/lib/perl) at
/usr/lib/perl5/site_perl/5.6.0/i386-linux/Apache.pm line 3.
BEGIN failed--compilation aborted at
/usr/lib/perl5/site_perl/5.6.0/i386-linux/Apache.pm line 3.
Compilation failed in require at (eval 1) line 3.

                                                           [FAILED]
Comment 2 Chip Turner 2002-03-10 20:46:15 EST
Looks like you didn't upgrade to mod_perl 1.26 when you upgraded perl (they were
part of the same errata).  This problem should go away once you upgrade.  If you
are using RHN, you can use "up2date mod_perl" to get the upgrade, otherwise
download it from updates.redhat.com.

Note You need to log in before you can comment on or make changes to this bug.