Bug 609471 - Starting S->A->Services generates 13 identical blocks of message re rsyncd in syslog
Starting S->A->Services generates 13 identical blocks of message re rsyncd in...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-services (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On: 583842
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-30 07:39 EDT by Nils Philippsen
Modified: 2010-07-06 13:22 EDT (History)
1 user (show)

See Also:
Fixed In Version: system-config-services-0.99.46-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 583842
Environment:
Last Closed: 2010-07-06 13:22:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nils Philippsen 2010-06-30 07:39:17 EDT
+++ This bug was initially created as a clone of Bug #583842 +++

Description of problem: When displaying services, get 13 identical blocks of messages in the syslog when the rsync daemon is installed.

I don't know if even one block of messages should be emitted.  13 sure as heck is excessive.  Very annoying when trying to debug a named issue.


Version-Release number of selected component (if applicable):
F13 beta i686, all updates

How reproducible: 100%


Steps to Reproduce:
1. install rsync deamon
2. view syslog
3. Start System->Administration->Services
  
Actual results:
System->Administration->Services generates following in syslog for a single invocation:


Apr 19 17:19:47 wallace xinetd[1245]: Starting reconfiguration
Apr 19 17:19:47 wallace xinetd[1245]: Swapping defaults
Apr 19 17:19:47 wallace xinetd[1245]: readjusting service rsync
Apr 19 17:19:47 wallace xinetd[1245]: Reconfigured: new=0 old=1 dropped=0 (services)
Apr 19 17:19:48 wallace xinetd[1245]: Starting reconfiguration
Apr 19 17:19:48 wallace xinetd[1245]: Swapping defaults
Apr 19 17:19:48 wallace xinetd[1245]: readjusting service rsync
Apr 19 17:19:48 wallace xinetd[1245]: Reconfigured: new=0 old=1 dropped=0 (services)
Apr 19 17:19:48 wallace xinetd[1245]: Starting reconfiguration
Apr 19 17:19:48 wallace xinetd[1245]: Swapping defaults
Apr 19 17:19:48 wallace xinetd[1245]: readjusting service rsync
Apr 19 17:19:48 wallace xinetd[1245]: Reconfigured: new=0 old=1 dropped=0 (services)
Apr 19 17:19:48 wallace xinetd[1245]: Starting reconfiguration
Apr 19 17:19:48 wallace xinetd[1245]: Swapping defaults
Apr 19 17:19:48 wallace xinetd[1245]: readjusting service rsync
Apr 19 17:19:48 wallace xinetd[1245]: Reconfigured: new=0 old=1 dropped=0 (services)
Apr 19 17:19:48 wallace xinetd[1245]: Starting reconfiguration
Apr 19 17:19:48 wallace xinetd[1245]: Swapping defaults
Apr 19 17:19:48 wallace xinetd[1245]: readjusting service rsync
Apr 19 17:19:48 wallace xinetd[1245]: Reconfigured: new=0 old=1 dropped=0 (services)
Apr 19 17:19:48 wallace xinetd[1245]: Starting reconfiguration
Apr 19 17:19:48 wallace xinetd[1245]: Swapping defaults
Apr 19 17:19:48 wallace xinetd[1245]: readjusting service rsync
Apr 19 17:19:48 wallace xinetd[1245]: Reconfigured: new=0 old=1 dropped=0 (services)
Apr 19 17:19:48 wallace xinetd[1245]: Starting reconfiguration
Apr 19 17:19:48 wallace xinetd[1245]: Swapping defaults
Apr 19 17:19:48 wallace xinetd[1245]: readjusting service rsync
Apr 19 17:19:48 wallace xinetd[1245]: Reconfigured: new=0 old=1 dropped=0 (services)
Apr 19 17:19:48 wallace xinetd[1245]: Starting reconfiguration
Apr 19 17:19:49 wallace xinetd[1245]: Swapping defaults
Apr 19 17:19:49 wallace xinetd[1245]: readjusting service rsync
Apr 19 17:19:49 wallace xinetd[1245]: Reconfigured: new=0 old=1 dropped=0 (services)
Apr 19 17:19:49 wallace xinetd[1245]: Starting reconfiguration
Apr 19 17:19:49 wallace xinetd[1245]: Swapping defaults
Apr 19 17:19:49 wallace xinetd[1245]: readjusting service rsync
Apr 19 17:19:49 wallace xinetd[1245]: Reconfigured: new=0 old=1 dropped=0 (services)
Apr 19 17:19:49 wallace xinetd[1245]: Starting reconfiguration
Apr 19 17:19:49 wallace xinetd[1245]: Swapping defaults
Apr 19 17:19:49 wallace xinetd[1245]: readjusting service rsync
Apr 19 17:19:49 wallace xinetd[1245]: Reconfigured: new=0 old=1 dropped=0 (services)
Apr 19 17:19:49 wallace xinetd[1245]: Starting reconfiguration
Apr 19 17:19:49 wallace xinetd[1245]: Swapping defaults
Apr 19 17:19:49 wallace xinetd[1245]: readjusting service rsync
Apr 19 17:19:49 wallace xinetd[1245]: Reconfigured: new=0 old=1 dropped=0 (services)
Apr 19 17:19:49 wallace xinetd[1245]: Starting reconfiguration
Apr 19 17:19:49 wallace xinetd[1245]: Swapping defaults
Apr 19 17:19:49 wallace xinetd[1245]: readjusting service rsync
Apr 19 17:19:49 wallace xinetd[1245]: Reconfigured: new=0 old=1 dropped=0 (services)
Apr 19 17:19:49 wallace xinetd[1245]: Starting reconfiguration
Apr 19 17:19:49 wallace xinetd[1245]: Swapping defaults
Apr 19 17:19:49 wallace xinetd[1245]: readjusting service rsync
Apr 19 17:19:49 wallace xinetd[1245]: Reconfigured: new=0 old=1 dropped=0 (services)

Expected results:
1 copy, at most!

Additional info:

--- Additional comment from jzeleny@redhat.com on 2010-06-01 09:28:32 EDT ---

Each of these blocks means xinetd received a signal for reconfiguration (I believe it is SIGHUP). I suggest to look at the application that sends these signals. I'm adding maintainer of system-config-services to CC. Maybe he knows what's going on.

Nils, can you take a look and give me a hint if this is caused by system-config-services? Thanks.

--- Additional comment from nphilipp@redhat.com on 2010-06-25 06:06:42 EDT ---

It is caused by s-c-services. When discovering an xinetd service, s-c-services set the "enabled" property (instead of the "_enabled" variable) of the service object, which triggered running "chkconfig --type xinetd ... {off,on}" and "service xinetd reload". I've fixed this in the source repository:

http://git.fedorahosted.org/git/?p=system-config-services.git;a=commitdiff;h=12da4db92d79b083f4b1ea77a3a49ebd396f7111
Comment 1 Fedora Update System 2010-06-30 07:39:51 EDT
system-config-services-0.99.46-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/system-config-services-0.99.46-1.fc12
Comment 2 Fedora Update System 2010-07-01 14:53:00 EDT
system-config-services-0.99.46-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-services'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/system-config-services-0.99.46-1.fc12
Comment 3 Fedora Update System 2010-07-06 13:22:40 EDT
system-config-services-0.99.46-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.