Bug 609476 - [elfutils] Translation for the string 'FILE'
[elfutils] Translation for the string 'FILE'
Status: CLOSED NOTABUG
Product: Fedora Localization
Classification: Fedora
Component: Japanese [ja] (Show other bugs)
unspecified
All Linux
low Severity low
: ---
: ---
Assigned To: Noriko Mizumoto
Noriko Mizumoto
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-30 07:50 EDT by masami256
Modified: 2010-07-07 00:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-07 00:00:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description masami256 2010-06-30 07:50:56 EDT
Description of problem:
"file" is translated to "ふぁいる" instead of "ファイル" in some help options.

Version-Release number of selected component (if applicable):
elfutils-0.148-1.fc13

How reproducible:
run elfutils command with "--help" option.

Steps to Reproduce:
1.eu-addr2line --help

1.eu-findtextrel --help

1.eu-nm --help

1.eu-objdump --help

1.eu-readelf --help

1.eu-size --help

1.eu-strings --help

1.eu-unstrip --help

Actual results:
"file" is translated to "ふぁいる"

Expected results:
"file" is translated to "ファイル"

Additional info:
These are actual results.

/usr/bin/eu-addr2line ng
-e, --executable=ふぁいる   ふぁいる 中のアドレスを探す
-M, --linux-process-map=ふぁいる

/usr/bin/eu-findtextrel 
Usage: eu-findtextrel [OPTION...] [ふぁいる...]

/usr/bin/eu-nm 
Usage: eu-nm [OPTION...] [ふぁいる...]

/usr/bin/eu-objdump ng
Usage: eu-objdump [OPTION...] [ふぁいる...]

/usr/bin/eu-readelf
Usage: eu-readelf [OPTION...] ふぁいる...

/usr/bin/eu-size 
Usage: eu-size [OPTION...] [ふぁいる...]

/usr/bin/eu-strings
Usage: eu-strings [OPTION...] [ふぁいる...]

/usr/bin/eu-strip
  -f ふぁいる            抽出した取り除いたセクションを
                             ふぁいる に置く
  -F ふぁいる            -f パラメーターの代わりに 名前
                             ふぁいる を有効にする

/usr/bin/eu-unstrip 
-e, --executable=ふぁいる  -M, --linux-process-map=ふぁいる
                             Linux の /proc/PID/maps 形式の ふぁいる   ふぁいる 中のアドレスを探す
Comment 1 Noriko Mizumoto 2010-06-30 21:31:14 EDT
This package name is: elfutils
Package description: 'A collection of utilities and DSOs to handle compiled objects'
Translatable file (PO): 'https://translate.fedoraproject.org/projects/p/elfutils/c/master/'

'file' is translated as 'ファイル' in Katakana.
However, 'FILE' is translated as 'ふぁいる' in Hiragana.

I see that Hiragana does not make sense but not sure that this can be replaced with Katakana, rather it seems safer to me leaving as 'FILE' in English.

For example,
msgid: Find addresses in FILE
msgstr: ふぁいる 中のアドレスを探す

The program looks for addresses in FILE. If 'FILE' is translated, can the program still find addresses in file? Any idea?
Comment 2 masami256 2010-07-01 09:01:59 EDT
Thank you for explained it. 
I got it that Japanese doesn't have upper and lower case latter. so it's quiet difficult to translate.
However, should "FILE" be translated? In the po file, "[fF]ile" and "FILE" are different use. IMPOV it's necessary to translate "[fF]ile" as "ファイル" to make sentence natural. I think use "FILE" instead of translated word can be OK, because it's still the sentence natural.

Cheers,
Comment 3 Noriko Mizumoto 2010-07-01 22:48:41 EDT
Hi Roland

It seems that you are the owner of 'elfutils', and would like to ask for help.
Does 'FILE' (upper case) need to be treated as special, separate from usual 'file'?

Description of problem:
There are two types of 'file' and 'FILE' in elfutils. Translator is unable to determine whether those two to be translated with same one term or those to be differentiate with two separate terms. 

Version-Release number of selected component (if applicable):
elfutils-0.148-1.fc13

How reproducible:
run elfutils command with "--help" option.

Translatable file (PO):
'https://translate.fedoraproject.org/projects/p/elfutils/c/master/'
Comment 4 Roland McGrath 2010-07-02 14:34:22 EDT
I can't tell you how to translate.  In those usage messages, as is the normal convention for usage messages, there are words in all caps like FILE or SECTION that represent an argument to the command, where the actual argument is some particular file name the user chooses, etc.  The uses with normal capitalization (such as "file" in all lower-case) are normal English uses of the word in an English phrase such as "Print name of the input file".  So the latter is to be translated however that English sentence (or sentence fragment) is ordinarily translated.  The former is to be translated in whatever is the normal convention for displaying what we call "metasyntactic variables", i.e. an identifier that stands in for some arbitrary piece of user input.

There is nothing special to elfutils about this.  Using all-caps words in this way is the normal convention used in all --help messages throughout the system, and many other places too.  So your translation team should have a well-established convention for how to represent this in your language.
Comment 5 Noriko Mizumoto 2010-07-06 22:46:14 EDT
Thanks Roland,
Understood how all caps words work in help messages.

AFAIK, there is no established convention for those or generally known way either in Japanese. It seems to me that the way we can go would be either to translate into exact same style of normal capitalization (Katakana) or to leave them as is in English as masami256 suggested.
Unless an better approach is suggested, I would go with latter of leaving in English.
Comment 6 Roland McGrath 2010-07-07 00:00:32 EDT
There are many uses of all-caps names for arguments and the like in help strings of many packages.  It is certainly the convention for such uses in all GNU programs.  I'd certainly say this is something that each translation team should have an official convention for, or at least a FAQ entry of some kind.  But that is up to the translation teams to figure out, and for the translation project's administrators to encourage teams to do.
Comment 7 Roland McGrath 2010-07-07 00:01:24 EDT
Oh, sorry, just realized this was not for my component and I shouldn't have closed it.  Please reopen or whatever is appropriate.

Note You need to log in before you can comment on or make changes to this bug.