Bug 609515 - [abrt] system-config-printer-1.2.3-3.fc14: authconn.py:102:set_auth_info:TypeError: Gtk.Entry.set_text() argument 1 must be string, not None
[abrt] system-config-printer-1.2.3-3.fc14: authconn.py:102:set_auth_info:Type...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
14
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
abrt_hash:bd4424c7
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-30 09:24 EDT by Horst H. von Brand
Modified: 2010-09-15 03:17 EDT (History)
4 users (show)

See Also:
Fixed In Version: system-config-printer-1.2.4-2.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-15 01:28:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (722 bytes, text/plain)
2010-06-30 09:24 EDT, Horst H. von Brand
no flags Details

  None (edit)
Description Horst H. von Brand 2010-06-30 09:24:22 EDT
abrt version: 1.1.5
architecture: x86_64
cmdline: python /usr/share/system-config-printer/system-config-printer.py
comment: The above because the HP LaserJet 3020 ran low on toner, but changing the toner didn't get it to print. So I wanted to delete + recreate it.
component: system-config-printer
executable: /usr/share/system-config-printer/system-config-printer.py
kernel: 2.6.35-0.2.rc3.git0.fc14.x86_64
package: system-config-printer-1.2.3-3.fc14
reason: authconn.py:102:set_auth_info:TypeError: Gtk.Entry.set_text() argument 1 must be string, not None
release: Fedora release 14 (Rawhide)
time: 1277904110
uid: 500

backtrace
-----
authconn.py:102:set_auth_info:TypeError: Gtk.Entry.set_text() argument 1 must be string, not None

Traceback (most recent call last):
  File "/usr/share/system-config-printer/asyncipp.py", line 180, in prompt_auth
    self._auth_handler (prompt, self._conn, method, resource)
  File "/usr/share/system-config-printer/asyncipp.py", line 446, in auth_handler
    d.set_auth_info ([self._user, ''])
  File "/usr/share/system-config-printer/authconn.py", line 102, in set_auth_info
    self.field_entry[i].set_text (auth_info[i])
TypeError: Gtk.Entry.set_text() argument 1 must be string, not None

Local variables in innermost frame:
i: 0
self: <AuthDialog object at 0x238ac80 (GtkDialog at 0x23c5a50)>
auth_info: [None, '']

How to reproduce
-----
1. Deleted a networked printer
2. Started to recreate it
3.
Comment 1 Horst H. von Brand 2010-06-30 09:24:24 EDT
Created attachment 427995 [details]
File: backtrace
Comment 2 Jiri Popelka 2010-06-30 10:28:19 EDT
If you are able to reproduce it,
can you start the program from command line
'system-config-printer --debug'
and post the output here ?
thanks
Comment 3 Tim Waugh 2010-06-30 11:07:51 EDT
Not sure about how to reproduce it but this is happening because we left self._user as None in the AuthDialog class.  We need to fill in *something* for the username field in the authentication dialog, so before calling set_auth_info we should check if it's None and, if so, set it to cups.getUser().
Comment 5 Horst H. von Brand 2010-07-01 19:07:54 EDT
Sorry, but I fixed the problem that gave me this. We used to have a HP LaserJet 3020 as stated, but it was changed for a HP LaserJet M1522nf MFP. When that one ran low on toner, the toner was changed but CUPS had wedged somehow (AFAIU, it tried to inquire the toner status via whatever the old one used, and the new one didn't understand) I tried to unwedge by deleting/recreating the printer, and there it crashed. Afterwards creating the new printer worked fine.
Comment 6 yantrikig 2010-07-18 20:14:08 EDT
Package: system-config-printer-1.2.3-3.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Started printer configuration.
2. Select add network printer
3.
Comment 7 Bug Zapper 2010-07-30 08:19:12 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Fedora Update System 2010-08-26 07:53:00 EDT
system-config-printer-1.2.4-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/system-config-printer-1.2.4-1.fc13
Comment 9 Fedora Update System 2010-08-26 07:55:32 EDT
system-config-printer-1.2.4-1.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/system-config-printer-1.2.4-1.fc14
Comment 10 Fedora Update System 2010-08-26 14:35:53 EDT
system-config-printer-1.2.4-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/system-config-printer-1.2.4-1.fc14
Comment 11 Fedora Update System 2010-09-13 14:08:02 EDT
system-config-printer-1.2.4-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/system-config-printer-1.2.4-2.fc14
Comment 12 Fedora Update System 2010-09-15 01:27:39 EDT
system-config-printer-1.2.4-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2010-09-15 03:17:00 EDT
system-config-printer-1.2.4-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.